Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
w202 c2oo sport,and an awsome 300zx tt z32
Joined
·
6 Posts
Discussion Starter #1
hello again had another problem occur with my c 200 sport ..driving up the highway around 70mph all fine. i came to an island a and stopped for traffic and as i pulled off it was like it pulled away i 2nd ,further up the road i noticed that it wouldnt change gear so stopped on the side of the road engaged park then back to drive.no drive,so i turned the engine off and then back on,engaged drive still stuck in 2nd.i had to travel 30miles whilst stuck in second(not nice).has any1 had this issue,is my autobox dead,or does the oil need to be changed.the gearbox code is 722,422,any ideas please as im not willing to replace the autobox due to the expense of it...lee:crybaby2:
 

·
Registered
2001 CLK55 AMG, 2002 C32 AMG
Joined
·
1,637 Posts
well, there are a number of things that could be wrong with your tranny. you say you have 722.422 so it sounds like its the vacuum controlled tranny. what year is your car? i would start by checking your vacuum lines that go from your transmission to the upshift delay switchover vavle and also check the lines that go from the tranny at the modulator to the intake manifold. have you checked your tranny fluid level? is it low? high? is it red? black? i would say that a transmission fluid change is probably a good thing to do at this point anyway if its never been done.

so the transmission is stuck in second and only second? do you have a mode switch for your transmission?
 
1 - 2 of 2 Posts
Top