Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
2002 E430 - Anyone know how to reset the climate control unit, I can't turn off the (EC) mode on my unit - I noticed that my AC wasn't blowing any cold air, and I could not turn off the economy mode (EC) off. This is preventing the AC from meeting the climate setting.

Thank you in advance for any tips or ideas.
 

·
Registered
E220T cdi
Joined
·
28 Posts
I had the same problem a while ago and in my case it was a simple and cheap fix luckily! Take a look at the link below, specially Sokoloffs post.

http://www.benzworld.org/forums/forums/thread-view.asp?tid=1175387&posts=13&hl=


Morgan
 

·
Registered
1959 220S cabriolet, 1983 240D original owner, 1999 E300 turbo diesel, 1988 560SL, 2003 SLK320
Joined
·
3,513 Posts
Somewhat common problem I think. All the details are here - http://www.mercedesshop.com/shopforum/showthread.php3?s=&threadid=86110

Especially read the second page.

Len
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Thank you for the earlier feedback, it was very helpful in getting the below data. Can someone help me interpret this data; the actual data is from a 2002 E430 after it has been sitting for approx. 1hr after a 30 minute drive.

Actual Output

1 80
2 69
3 93
4 94
5 89
6 155
7 00
8 93
9 27
10 3.0
11 3.2
12 4.3
20 3.2
21 32
22 00
23 32
24 11.4
40 164
41 91
42 72
43 136

Diag Error codes:
eb1 234
eb1 416
eb1 422
eb1 241
e ff
e
 

·
Registered
E220T cdi
Joined
·
28 Posts
You have some errorcodes but they could be old and not relevant, since they doesn't dissappear without erasing them as far as I know:

E 1234 = Sun Sensor
E 1416 = Coolant Circulation Pump
E 1422 = Series I-Face Connection to Instrument Cluster
E 1241 = Refrigerant Refill
E FF = End Of Errors

I did also have these errorcodes exept the 1241 but they where not relevant and I erased them and they didn't come back.

The thing is that you have the item #7 (Refrigerant Pressure) = 0 and E1241 that makes me suspect that you are low on refrigerant and may have a leak, this will cause the software to turn on the EC in order to prevent the system for further damage.

First of all you can erase the errorcodes by getting into errorcode mode and push both the blue and red arrows at the right side (if I remembered it right), hold them for a couple seconds.

Check the sensors #1 #3 #4 #5 in the morning, they all should be approx. the same.

Morgan
 

·
Registered
1959 220S cabriolet, 1983 240D original owner, 1999 E300 turbo diesel, 1988 560SL, 2003 SLK320
Joined
·
3,513 Posts
Tech bulletin from mercedes says to change the sensor in all cases. Reprogram the unit and then see what codes you have. See my reference above.

Len
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
I ran the diag. again this morning after the car sat over night: (outside temp was reporting 55deg.)

1 60
2 53
3 67
4 67
5 66
6 75
7 00

I had the AC charged last year by the dealer; AC worked fine all year. They might have injected the dye in order to detect leaks at that point. I'll try resetting the error codes and see what continues to report back.

Thank you again - Scott
 
1 - 7 of 7 Posts
Top