Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
2003 C180K
Joined
·
3 Posts
Discussion Starter #1
Hi

I have an Audio10 radio/cd as originally installed in a 2003 C180k. Reception on FM was OK. On MW/LW and SW it was rubbish - very weak except for local stations. The car was examined under warranty by a MB dealer who replaced the radio. Replacement made no difference - radio performance is as before. As there is no external antenna I presume it uses the heated rear window as an antenna. Is that the problem? Is there an amplifier assembly that could be a t fault - if so where is and how does one tell. I would normally expect strong signals on the short wave channel even with a few feed of wire as antenna so something is clearly wrong there.

The car runs out of warranty in about 2 months so it would be nice to get this sorted properly within that time.

Thanks in advance for any suggestions/diagnosis.
[:(]
 

·
Registered
2002 C230k
Joined
·
1,246 Posts
There is an antenna amplifier in the top of the hatch. Usually, but not always, the remote key won't open the car from a distance if the amp is bad.
 

·
Registered
Joined
·
3 Posts
check and make sure the antenna wire is intact and hasn't been nicked which could significantly shorten the length of the antenna
 

·
Registered
2003 C180K
Joined
·
3 Posts
Discussion Starter #4
Hi Lynn

thanks for the reply.

What exactly do you mean by "in the top of the hatch" - do you mean above the boot i.e. below the rear window?. Its a "sedan" rather than the sports coupe so no "hatch" in the european sense anyway.

Any ideas on accessing the amplifier? how well buried is it?

The remote access via the key works to a reasonable distance - 20 yds or so anyway so possibly that means the amp is OK?

Even if I do not tackle it myself I would like to be able to go back to the dealer with some pretty direct suggestions. I won't complain about the replacement of the radio as it cost me nothing.

Regards
[:)]
 

·
Registered
2003 C180K
Joined
·
3 Posts
Discussion Starter #5
Thanks for the comment. It looks to me that the radio was in and out a number of times for whatever reason so could be some scope for wiring problems associated with it. However, the FM band does work fairly well -- though not as good as the Blaupunkt in my old VW Passat did.

I am presuming the rear window is used as the antenna but wonder if that is actually the case? or if there is some alternative being used?

I wonder in the limit whether anyone has fitted an external antenna instead of the rear window?
 

·
Registered
2002 C230k
Joined
·
1,246 Posts
The antenna amp will be above the rear window in a sedan. The trim around the window needs to be removed. Since the key seems to work from a good distance, there might be a problem with the antenna cable connections. The antenna is in the rear window. If you look closely, some of the wires are not used for defogging the window. Those wires are the antenna.
 
1 - 6 of 6 Posts
Top