Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
2000 Mecedes-Benz C230
Joined
·
30 Posts
Discussion Starter #1 (Edited)
I have had a problem with my 2000 M-B c230 with rough idle and hesitation. I replaced my spark plugs,coils and MAF sensor and it is still doing the same thing. Does anyone out there have any idea what problem is; it happened all of a sudden no warning. By the way check engine light is on too.
 

·
Registered
1998 c230 170K
Joined
·
1,415 Posts
Did you scan for codes and how many miles are on the car now? Has the fuel and air filter been changed recently? Check your vacuum hoses for looseness or cracks. The throttle body may be gummed up, you might want to clean that and make sure the butterfly isn't sticking. Poor quality or lower grade gas can cause issues too. A cracked coil can do weird things as well. B
 

·
Registered
2000 Mecedes-Benz C230
Joined
·
30 Posts
Discussion Starter #4
Did you scan for codes and how many miles are on the car now? Has the fuel and air filter been changed recently? Check your vacuum hoses for looseness or cracks. The throttle body may be gummed up, you might want to clean that and make sure the butterfly isn't sticking. Poor quality or lower grade gas can cause issues too. A cracked coil can do weird things as well. B
it has approx 108,000 miles the codes read misfiring on cyl 2 and 4 which is why i replaced all those parts. i have heard about the trottle body but do you know wher its located. my car has a airfilter box but the maf is not attached to that its on the other side of the motor. is the trottle body on the airfilter side or the maf inlet side? Thanks for responding
 

·
Registered
1998 c230 170K
Joined
·
1,415 Posts
The throttle body is one the driver's side, you will have to remove the snorkle to access the area for inspection and cleaning. I am not discounting a coil malfunction as mentioned already or wiring issue at this point you may have a bad contact problem. There are suppressor contacts to the coils that can dry out and make poor contacts. What did the old plugs look like when you pulled them? Black? White, dry, wet? B
 

·
Registered
2000 Mecedes-Benz C230
Joined
·
30 Posts
Discussion Starter #6
ok i went to advance auto and these are the codes coming up p0100, p0110, p0300, p0302, p0304. Plugs were original to car and were pretty beat.
 

·
Registered
2002 ML55 AMG, 2005 Chrysler Crossfire Coupe Limited, 1999 C280
Joined
·
4,714 Posts
I'm sorry to hear about your problem.

Dirty throttle body aside, my bet is you bought a knock-off MAF from somewhere like Ebay.

Purchase a genuine Bosch MAF from a reputable vendor and you're good to go.

IF you purchased a genuine MAF then check that your MAF connections (plugs and wires) are as they should be.
 

·
Registered
2000 Mecedes-Benz C230
Joined
·
30 Posts
Discussion Starter #10
update-finally got fed up and took to garage they told me fuel injector 2 was messed up so i had replaced it was stuck open. the motor still does same thing the engine light is still on and when I give it gas or rev it up it hesitates like the fuel pump cant keep up or something I'm ready to drive this car "accidentally " into a wall.
 

·
Registered
2000 Mecedes-Benz C230
Joined
·
30 Posts
Discussion Starter #11
by the way I might try the trottle body next what do I have to loss...thanks for your suggestions though i do appreciate them
 
1 - 11 of 11 Posts
Top