Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
400 SE
Joined
·
131 Posts
Discussion Starter #1
hello to all ,
i just check the eta unit and all the wires are like new:eek: , i replace the old maf , the asr fault still there but the eta is working fine ,
somebody knows what makes the ASR fault goes on whitout beeing the ETA ??
:surrender:
 

·
Registered
Joined
·
5,344 Posts
There's about a dozen things, or maybe it's two dozen, I forget. You need to build the code reader and read the fault codes on the 38 pin diagnostic connector in the engine compartment.
 

·
Registered
400 SE
Joined
·
131 Posts
Discussion Starter #6
There's about a dozen things, or maybe it's two dozen, I forget. You need to build the code reader and read the fault codes on the 38 pin diagnostic connector in the engine compartment.

how to built the code reader ?

by the way i think that MB didnt put a diagnose sistem to the ETA, right ?
 

·
Registered
Joined
·
5,344 Posts
how to built the code reader ?

by the way i think that MB didnt put a diagnose sistem to the ETA, right ?
See "home brew" at the bottom of the page - K6JRF Auto Page

There are some faults relating to the idle control system including the throttle actuator. It's not real refined when it comes to telling you why the ASR light, but still it's the best place to start.
 

·
Registered
CLS350 C219 2006
Joined
·
582 Posts
See "home brew" at the bottom of the page - K6JRF Auto Page

There are some faults relating to the idle control system including the throttle actuator. It's not real refined when it comes to telling you why the ASR light, but still it's the best place to start.
Hi,

had many 'random' faults with my 92/93 500SEL.
Eventually I considered maybe the systems are all ok, but the central component that ties all faults together is the connector bank for all ECUs.
Unplugged and re-inserted all of them (while batterie minus disconnected) , all but 3 faults are gone. Did a 5 hour test drive including rugged road.
May not be the same for you, but worthwhile considering.

Cheers
 

·
Registered
1997 400SE
Joined
·
12 Posts
can you explain a little more about that . i have that option in my 94 s420, and having the ASR light on.
__________________
Turned on engine, snow chain light was on along with ASR and ABS lights - checked manual said to turn off snow chain light, when I hit it for it to go off, it stays on. I've tried it with the engine running, in different key positions, in neutral - none of the lights will go off. The steering is heavier too
 

·
Registered
400 SE
Joined
·
131 Posts
Discussion Starter #11
See "home brew" at the bottom of the page - K6JRF Auto Page

There are some faults relating to the idle control system including the throttle actuator. It's not real refined when it comes to telling you why the ASR light, but still it's the best place to start.

thank you i will try to built one:thumbsup:
 
1 - 11 of 11 Posts
Top