Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
W140 1993 500SEL
Is there a way to disconnect the ASR system? I was just told that my ASR unit is going out. THe ASR light came on and the thottle went to 10-15%.
Then I stopped for and hour and the light was off when I started up again. The triangle light came on 2 hard left hand turns,and then went out. Again the thottle was reduced. A tech rep said my ASR unit is going out. He said I will loose complete thottle shortly. On the newer models there is a shut off switch. Can one be placed in line on this year car?
 

·
Registered
Joined
·
4 Posts
I have the exactly same problem with my 1994 500SEC. First of all you will never loose the complete thottle. I have driven almost 100.000 km with this problem with no chage except that the functionality is intermittent. From a user point of view its not possible to turn the ASR system off - from a diagnostic view I really don't know?

How much did the repair shop wanted for a new ASR unit? My local dealer wanted over 1800 euro! Maybe its worth checking the wheel speed sensor to the ASR before ordering a new ASR unit?
 

·
Registered
94sl-600
Joined
·
65 Posts
the engine compartment (and ETA) wiring harnesses are a well known problem on that model. They will cause the problem you describe.
Unfortunately, the ETA wiring harness is not available--only complete ETA assemblies. Fortunately you have only 1 and I think it is about $1200 right now (may be $2500 by now though with MBZ's crazy parts price jumps recently) Have the tech slit open the wiring harness bundles (in high heat locations) and check condition of the individual wires.

There is a link on mercedesshop.com (sl section) showing how to rewire the ETA harness.
 
1 - 4 of 4 Posts
Top