Mercedes-Benz Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
1,621 Posts
Discussion Starter #1
I need a part under the gas tank. Can anyone help me out?

I really am trying to avoid spending $65 on a part that is ultimately a gamble right now.
 

·
W124 Moderator
86 190E 2.3L 16V, 2 95 320TE's, 02 S500
Joined
·
12,758 Posts
Does the part under the gas tank happen to have a name or part number? When you say under the tank, what does that mean? Inside the trunk or under the car?

Sent from my DROID2 using AutoGuide.Com Free App
 

·
Registered
Joined
·
1,621 Posts
Discussion Starter #4 (Edited)
Eddie don't have it. Tried that before the thread.

Looking for a one way vent valve between tank on drivers side going to the evap canister.


http://www.mbpartsworld.com/showAssembly.aspx?ukey_assembly=1076067

Item 5 in link


Sent from my SGH-T989 using AutoGuide.Com Free App
 

·
Premium Member
1997 S600 (sold)
Joined
·
4,660 Posts
You've got a problem with the OBDII system readiness monitor not showing up "ready" right? Or do you have a fault code issue? What's the problem exactly?

I vaguely recall you mentioning this before. How did your mechanic come to the conclusion that this valve was an issue?

Brett
 

·
Premium Member
84 500 SEL ...94 S420..... 95 S500.... 96 S500 95 S600
Joined
·
1,707 Posts
I need a part under the gas tank. Can anyone help me out?

I really am trying to avoid spending $65 on a part that is ultimately a gamble right now.
Ill look better in the A.M. Im sure I can find one...
 

·
Registered
Joined
·
1,621 Posts
Discussion Starter #7
You've got a problem with the OBDII system readiness monitor not showing up "ready" right? Or do you have a fault code issue? What's the problem exactly?

I vaguely recall you mentioning this before. How did your mechanic come to the conclusion that this valve was an issue?

Brett
Correct closed loop fault issue.

My car is missing this part. As in someone replaced the hoses and no valve installed. According to a member on here that was strongly adamant about this missing part being my actual reason.

Sent from my SGH-T989 using AutoGuide.Com Free App
 

·
Registered
1991 Mercedes Benz 300E, 179K, stock, daily driver
Joined
·
1,689 Posts
Huh???

Sent from my SAMSUNG-SGH-T989 using AutoGuide.Com Free App
well some people think they scam, some people think they have bad customer service, some people think their reliable and some people think their great. Its 50/50 for parts geek, maybe you'll be lucky :cool:
 

·
Registered
1995 mercedes S420
Joined
·
228 Posts
well some people think they scam, some people think they have bad customer service, some people think their reliable and some people think their great. Its 50/50 for parts geek, maybe you'll be lucky :cool:
lol, i been purchasing parts form them for a long time and they really have a good costumer service and quick response to email, and calls. they respect costumers specially Mike, i think thats his name . hes really good.
this is not a commercial for Geeks part but thats who i deal with if i cant find my part on ebay.
 
1 - 15 of 15 Posts
Top