Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
94 E320 Cabriolet, 2006 E350 4Matic
Joined
·
1 Posts
Discussion Starter #1
All of a sudden after unlocking and opening the drivers door, the anti-theft alarm kicked in and would not turn off. It would cycle then shut off, but if I opened a door, trunk or hood, it came back on. I pulled the two fuses in the Auxilary Fuse Holder (F14) but the relay kept clicking and the horn kept honking ( the headlamps did stop flashing). I disconnected the security horn but still the relay was clicking behind the glove box.

Any ideas? A new Anti-Theft alarm module cost $300. plus and I'm not interested in that much of a cure without knowing if this is what is wrong.

David Saidel

[xx(]
 

Attachments

·
Registered
Joined
·
5 Posts
alarm

I had the same problem...luckily I have a battery cut-off switch which turned everything off before I woke the entire neighborhood. Not that it is the solution...

The way I turned it off was to insert the key into the driver's side door and turn the key to the right...then left. Or left then right.

If all else fails, get a battery cut off switch and cut the battery for 3 minutes. That usually does the trick.

Hope that helps.
 

·
Registered
86 560sl 99 ml320
Joined
·
21 Posts
same thing happens to my 89 190e. Thank God the horn doesn't sound... just the flashing lights whenever I use the vacuum lock system from any door other than the driver's side.

The left, right, left thing works with the key in the driver's door. My mechanic says this is common for that alarm system.
 
1 - 3 of 3 Posts
Top