Mercedes-Benz Forum banner

1 - 14 of 14 Posts

·
Registered
2008 ML350
Joined
·
16 Posts
Discussion Starter #1
94 SL320, antennae was stuck and would not move. Motor still operates (can hear it). Replaced antennae but there still is no movement. Any advice?[:(]
 

·
Registered
92 300E
Joined
·
78 Posts
I had something similar on my 1996 SL500. Antenna stopped going up and down, though I c...

I had something similar on my 1996 SL500. Antenna stopped going up and down, though I could hear the motor. I tried replacing the mast, but to no avail. Had to get a whole new assembly for $300. But I hear that the other possible one is like $700.00.

Good Luck.
 

·
Registered
2000 Obsidian Black Metallic Mercedes SL 320 V6
Joined
·
4,527 Posts
Hi ppl... I've seen power antennas mounts for far less than how much u quote on ebay so I think u should have a look there if u intend to replace the whole assembrly.
Hope it helps.

Cheers.
 

·
Premium Member
Black SL 500 1994
Joined
·
1,026 Posts
Black300E said:
I had something similar on my 1996 SL500. Antenna stopped going up and down, though I could hear the motor. I tried replacing the mast, but to no avail. Had to get a whole new assembly for $300. But I hear that the other possible one is like $700.00.

Good Luck.
After having paid GBP 250 (almost 500 USD) for a Hirschmann power aerial two years ago I've since then always thought I got screwed pretty badly (excuse my French). But I guess the Hirschmann must be of a very good quality after all. I understand Hirschmann is the OEM part, I had a non-power one previously.
I have seen similar looking non-power aerials at 1/10 the cost, but apparently they are not that good. Well, at least I hope so... :-D
 

·
Registered
1997 SL500
Joined
·
32 Posts
1997 Sl500

I have the same problem, Motor running, mast is stationary. I opened up the motor housing (being mechanically inclined) ... there are 2 gears inside which pull and push the nylon cord. On 1 gear is a "nub" (broken off on mine)...with nub broken off, the gear to push/pull mast does not turn...I just contacted Hirscmann Antenna Co.... there is a company that makes these replacement gears ( appears to be one of most common reasons for mast not moving...Name and # ...Gary @ 770-781-5658... Hope this helps...
 

·
Registered
SL320/ML320
Joined
·
169 Posts
Must be someting in the air. My antenna died yesterday as well. Motor runs but the antenna does not move. There has to be an alternative to the Hirschmann. It was specialized for the OEM phone and the radio.

Anybody?
 

·
Registered
1990 500SL
Joined
·
71 Posts
I also had the problem and was looking at the Hirshmann OEM replacement, anyway thought it to expensive so had a local radio fitter out of yellow pages put me in a new one, cost €80 fitted at my office it works well looks Ok and is cheap to replace if it breaks again. It took him about 45 minutes to do. The Hirshmann might be good but not at $300. Sorry don't know make but it looks like many available on ebay.
 

·
Registered
SL500
Joined
·
4 Posts
I had the same thing happen in my '95 last year.

Seeing that a new assembly was going to cost over $300 I decided to take it out and see if I could fix it. (Nothing to lose since it was already broken.)

When I took it appart I found that a small plastic catch had broken off one of the two interconnected gears inside the unit. That was the whole problem.

So I drilled a small hole where that plastic catch broke off and put a small simialrly sized bolt in it is place. Put the unit back together and it has been working flawlessly ever since.

Entire project from start to finish was about an hour and a half (including the time spent trying to glue the plasitc catch instead of just replacing it).
 

·
Registered
Joined
·
36 Posts
I've not even attempted to take mine apart yet, but I just wanted to say thanks to people like *points above*. It's people like you that make it affordable for us regular folks to have older luxury vehicles that still draw attention like they were $100,000+ like new ones. Paying $15,000 for a car that was $115,000 new is grrreeeaaat! :)
 

·
Banned
Joined
·
230 Posts
I had mimne replaced at a non-Benz mechanic in Tokyo for 15,000 yen which is about US$140, it's perfect. Not sure where you all get the $300 price from?
 

·
Registered
SL320/ML320
Joined
·
169 Posts
Got mine fixed yesterday. It was the broken reel. The two reels separated and the part that pulls the mast was not turning. I put a screw in the two pieces and ground it down so it would not catch. Installed new mast and away we go.
 
1 - 14 of 14 Posts
Top