Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
mercedes 300sel
Joined
·
143 Posts
Discussion Starter #1
Hi everyone and i hope you can help me out a bit. i just purchased a new antena mast becasue the old one was bent. i placed the new mast into the motor and when it puled it down it didnt go all the way down. what can be the problem? im thinking that when i replaced the antena the toothed section a piece of it still remain in the motor? can this be the problem? anyone have any advice? thank you
 

·
Premium Member
89' 560SEL, 92' 300CE
Joined
·
418 Posts
Hmmmm... well, I wanna assume that you had the antenna button (inside the car) in the extended position. I thought that even if there was a broken piece you would be able to see it and pull it out...maybe not I guess.
Are you sure you pushed the new one in as far as you could before hitting the switch down to retract? I know it took me two times to get it perfect. Even if there is a piece in there, I don't think it can hurt. Just can't put your new one down all the way. Good luck.
 

·
Registered
mercedes 300sel
Joined
·
143 Posts
Discussion Starter #3
yeah thast what i mean. it does go down but not all the way. so i guess in order for it to go down all the way i need to take out that extra piece?
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Hello,

Yes, you have to remove the broken piece. Disassemble the motor housing and pull the broken piece out. Did that to mine. Now it goes all the way in.

By the way, look at how it was installed before you disassemble it. Had quite a bit of "fun" putting it back. Goodluck
 
1 - 5 of 5 Posts
Top