Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1 (Edited)
Hi all -
I'm wrapping up the replacement of my W124 E320 upper engine wiring harness (2933) and have found a couple of ports that look like something should be connected to them.

The first port looks to be about 12-13mm in diameter and is a barbed connector. It's located between injectors #4 and #5. It appears to be have been disconnected for some time.

The second port is under the little black box that is snugged up next to the throttle body. It looks like it should have one of those little hard plastic tubes plugged into it, but there is nothing in the engine compartment that I can find disconnected.

Thoughts?
 

·
Registered
Joined
·
153 Posts
Hi all -
I'm wrapping up the replacement of my W124 E320 upper engine wiring harness (2933) and have found a couple of ports that look like something should be connected to them.

The first port looks to be about 12-13mm in diameter and is a barbed connector. It's located between injectors #4 and #5. It appears to be have been disconnected for some time.

The second port is under the little black box that is snugged up next to the throttle body. It looks like it should have one of those little hard plastic tubes plugged into it, but there is nothing in the engine compartment that I can find disconnected.

Thoughts?
I have a late-95 Cabrio, and just went through this. No more late 95 harnesses (easily available) so my indy mech fit an early-95 harness on that involved retrofitting two sensors, I think MAF and coolant temp, I'll have to go back and look.

My guess would be your replacement is off, but hopefully adaptable.
 

·
Premium Member
Joined
·
1,826 Posts
I have a late coupe that calls for 124 440 4905 and so far NLA, would appreciate info on which "available" harness I should be looking for even if it needs modification(s)
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
I have a late-95 Cabrio, and just went through this. No more late 95 harnesses (easily available) so my indy mech fit an early-95 harness on that involved retrofitting two sensors, I think MAF and coolant temp, I'll have to go back and look.

My guess would be your replacement is off, but hopefully adaptable.
To be clear, the ports I'm talking about are vacuum or breather ports, NOT electrical connections. My 1244402933 harness fit perfectly.
 
1 - 7 of 7 Posts
About this Discussion
6 Replies
4 Participants
PhantomLord
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top