Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Premium Member
2002 Black SL500, 2000 Azure blue SL500, 2005 Silver (A209) CLK500
Joined
·
998 Posts
Discussion Starter #1
Cluster was "rebuilt."
1992 500 SEL.
Original problem. With the turn signal on....right/left or 4-ways....the outside temp gauge on the cluster, odometer, etc., and 4 way flasher button on the console wood trim flicker.
Sent it in for repairs..got it back...still flickers. Called the repair shop...was told...."we did some repairs to the circuit board that was causing the flickering...don't know what the problem could be." And I told them....the speedometer is "off" by 8 MPH. Speedometer shows 48 when traveling 40 or 28 when doing 20. Verified by GPS and cop radar.

1) What could be causing the flickering?
2) Gears in the speedometer....1 and 2 are always the same....the 3rd one causes the problems...so....does the 3rd gear also control the correct speed? If the shop installed a...let's say 32 tooth vs a 20 tooth...would that cause the error?
How does one know what correct gear to use if the original is not available?

Installed a different cluster...still flickers and MPH still wrong. Car has the original transmission, same wheels and tire size as original.
 

·
Registered
2006 S500 AMG Wifes Rig Hillbilly Girl 02 ML320
Joined
·
2,332 Posts
I think that PHameliton here on the forum would have the answer to that! Don't ask me how I know!!


Smokie
 

·
Registered
92 500SEL to 01 E320T current 2014 lexus LS460
Joined
·
3,886 Posts
I wish I could give you a better answer, but the speedometer receives its signal from the left front ABS speed sensor in the form of a sine wave (AC) it is converted in the ABS/ASR module into a square wave (pulsating DC) and fed to the cluster. The shop manual indicates the checking proceedure but unless you have a signal generator that produces 256 Hz for 27mph, up to 866Hz for 88mph, with no adjustment. You could check if your output of the sensor ring is 4volts AC at one rpm of the wheel. They do recommend checking of the voltage to the cluster but it seems complicated.
I question why you had the cluster rebuilt, and do they know what they are doing, the cluster usually exhibits flashing, when the washers or directional signal is activated and indicate a bad powersupply in the cluster. This is usually caused by a bad capacitor or voltage regulator, if you sent it in for the gears being locked up the wrong gears could have been installed. as far as I know the speedo is driven by a motor which also drives the odmeter.
http://www.odometergears.com/subpages/140_Speedometer_
MBCluster.com Mercedes W140 Instrument Cluster Repair Homepage
 

·
Banned
93 300se,92 300se,93 600 sel,92 500 sel,79 500slc,02 1.8t bug,01 a8,01 s80 t6,96 bmw 740il,86 rx7
Joined
·
822 Posts
Three tantilum caps need to be replaced. I can show you a picture and direct you to the parts. Let me know
 

·
Premium Member
2002 Black SL500, 2000 Azure blue SL500, 2005 Silver (A209) CLK500
Joined
·
998 Posts
Discussion Starter #5
Three tantilum caps need to be replaced. I can show you a picture and direct you to the parts. Let me know
Let's do it! Draw me a pic and where are the parts P!
 

·
Registered
2006 S500 AMG Wifes Rig Hillbilly Girl 02 ML320
Joined
·
2,332 Posts
Thanks Pat!! Btw: No more flashing in the rain anymore!! yeee haaaa!!


Smokie
 
1 - 6 of 6 Posts
Top