Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
A couple weeks back I posted about a CD player I hooked up, it would display the time but not turn on or play music. I was going to look into it but havent had time. Well today while I was sitting in the car with the car on the CD player started functioning out of nowhere and continued until I opened the ash tray to put some coins in it. Once I opened the ash tray it just shut off on me. Anyone have an idea what that might be? I cant get the thing to turn back on now. Is there a wire behind there that the the ash tray could be messing with?
I might pull all that out tomorrow morning, but I was looking for some idea of what to look for back there.
 

·
Registered
95 E320 Coupe, 11 E350 4Matic P2
Joined
·
1,082 Posts
Check the radio fuse first, if ok, then I would assume you have a bad ground connection somewhere, or worst case the deck isin't functioning too well...
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
It isnt the deck or the fuse, I think its the ground. I took the ashtray out and some of the ground wires (im guessing thats what those are all connected to that one junection) look a little touchy.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #4
So i figured it out finally. It wasn't the ground. I was reading that in the pre 8/85 cars the power for the radio ran in and out of the cigarette lighter, well it supposedly didn't for the post 9/85 cars, but mine did ( I own an 86 ). The thing is, it does run through the cigarette lighter and the cable going out to the radio was trashed, so when the ashtray was open it would complete the circuit but when closed the wires were apart. So since I dont smoke I just ran the power direct to the cd player and all works perfectly.
 
1 - 4 of 4 Posts
Top