Mercedes-Benz Forum banner

1 - 20 of 23 Posts

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Discussion Starter #1
Ok this is just to clarify. I pulled the vacuum line that comes off the EGR and plugged that vacuum line with a screw (screwed it in). The vacuum line (plastic) and rubber tube (w/screw) are now dangling above the EGR valve, while the EGR valve has an open tube. Is this the right way to plug it?

Or is it this way: Remove the vacuum line (plastic) from the vacuum tube (rubber--connected to EGR). In other words, keep the rubber vacuum tube on the EGR and plug it off from there. So is this the right way, as opposed to the one mentioned above where the EGR has an open tube where the vacuum line once attached to? It's kinda hard to describe.

Here might be a good description:

(EGR + rubber vacuum tube + screw) - (plastic vacuum line)

or

(EGR) - (rubber vacuum tube + screw + plastic vacuum line)

I notice that whenever I start my engine, it idles rough and once I step on the pedal a bit, it smoothens out. None like this when EGR vacuum line is connected to EGR itself.
 

·
Registered
1980 300D
Joined
·
309 Posts
Make it simple. Get those plugs Mercedes sells for the three way vacuum valve on the cam cover - they cost a couple of bucks at most. Plug the open tube in the EGR. Remove the vacuum line that fed the EGR at the other end - that's the temp sensor. Now Plug the two vacuum line fittings on the temp sensor. Plug the line that used to run to the temp sensor or better yet get another fitting and have one less vacuum line. No hanging vacuum lines, no muss, no fuss.
 

·
Registered
1982 300D Turbo
Joined
·
457 Posts
i have an answer, just take the egr OFF! and put a plate in the place of it. then u will b gettin pure fresh air. thats the way to do it. Then we will race[;)]
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Discussion Starter #4
I'll go for Douglas' advise. I don't want to take the whole thing off. I want to make it look all original still but be able to reinstall it back if needed. Thanks. I'll go get those plugs tomorrow and see what happens.

Marsh, you wanna race? [8)]
 

·
Registered
1982 300D Turbo
Joined
·
457 Posts
im down to race. we will look behind us while were speeding away yet to find a black cloud of soot![:)]
 

·
Registered
'81 300TD Turbo
Joined
·
416 Posts
Just pull the line at the EGR valve and plug it (plug the vaccum line). If you want to keep crap out of the EGR valve vaccum fitting, cap it. That's all you need to do. Don't know where all this plug this and plug that stuff is coming from.

From the EGR valve back to the 3way valve is one vaccum circuit. Plug it anywhere in the circuit and you've accomplished what you wanted. If you want to keep it original 'looking', do what karugs has suggested by inserting a BB in the rubber connector at the EGR valve and push it back on the EGR valve.

One thing to keep in mind when doing this is that if you disable the EGR, don't expect it to start working a year or two from now just by connecting it again. Chances are it may not. EGR valves have a tendancy to stop working when inactive for a while.
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Discussion Starter #7
Could you explain more how the EGR fails to function after a while? I haven't gotten the plugs yet, had to purge my car first. [:)]

Oh, I read a thread on Mercedes Shop about plugging the EGR and having no significant changes in quartermile times (roughly 20 seconds lol). Anybody care to confirm this or start an arguement? [:D]
 

·
Registered
1982 300D Turbo
Joined
·
457 Posts
i mean, honestly, the simple things you do to these diesels, wont change the 1/4 mile time that much. The egr just recirculates exhaust gas, i know u know this but if u think about it, how would the car go faster withought recirculating the exhaust gasses? It would be getting fresh air i understand but not much difference. I disconected my EGR anyways, better for the engine imensly. Eh Pat just plug your egr and call it even. that way when we race we will have equal mods on our cars. except that i have a not to long ago rebuilt tranny,straight pipe, and k&n filter. Hah im waitin for the day.

Smokin for life,
Marsh
 

·
Registered
1990 300SE, 1983 300D
Joined
·
1,201 Posts
I plugged my EGR yesterday and put a new air filter. I felt somewhat a difference. I think my blue Coupe was faster. I have a hole in my flex pipe so maybe thats robbing some horse.
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Discussion Starter #10
I know what you mean. But you have the weight advantage (no EGR, muffler or resonator [:D]) and I think you're running on higher boost lol

Why don't we just race to 200,000 miles? I only have a bit below your mileage to go lol j/k

I better clean my car before I race ya, if I lose at least it's shiny [:D]

Hey did you keep your stock air filter container? Or did you switch to the K&N ala-CAI style intake? I didn't get to see your engine

If anybody can explain to me how the EGR stops working after "disabling" it, I would appreciate it alot. I want to know more about our cars. Thanks

Oh, and I'm glad I plugged my EGR today. There was this Camry (2nd gen) who was zipping about. Come at an intersection both side by side. Light turns green and I floor it, he's gone. Seems like he missed his first shift lol... I only reached 50 bec speed limit was 45 and by the time I was there he wasn't even in my peripheral vision. Did a ricer flyby and I just smiled. He took off, maybe he was pissed lol
 

·
Registered
1982 300D Turbo
Joined
·
457 Posts
karugs - 4/19/2005 8:03 PM

I know what you mean. But you have the weight advantage (no EGR, muffler or resonator [:D]) and I think you're running on higher boost lol

Why don't we just race to 200,000 miles? I only have a bit below your mileage to go lol j/k

I better clean my car before I race ya, if I lose at least it's shiny [:D]

Hey did you keep your stock air filter container? Or did you switch to the K&N ala-CAI style intake? I didn't get to see your engine
Alright i didnt know if you were talkin to me or what, but ill answer anyways. First off i think you ment 300,000 miles cus im at 266,000. And im sure your paint on your car is in better condition than mine so nothing to worry about. And switching to that cold air intake is one of the DUMBEST things ive ever heard of. There is no point in it and it does NOTHING! The stock airbox gives cold air to the engine wich it likes so i just put a drop in k&n in mine. Im not sure if i wanna keep it now though due to people saying it doesnt filter as well as the stock air filter. Somebody put a little slab of grease on the inside of his k&n filter and ran it for a while and when he took the filter out and looked at the greas it was coverd with dirt. But i dont know, a k&n really doesnt do much more for the engine, dont get me wrong of course it improves the airflow but it also lets more dirt in the engine. I baught the filter when i was a young punk bout 2 years ago, so thats my excuse i guess[B)]. But for that 0-60 time i need to get a magellan gps or something to measure my speed cus my speedometer is off. it measures a little faster, anywhere from 5-10 mph faster than what im actually going. So my time would be fast i guess i could say[^] Well hears the beast not washed!
 

Attachments

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Discussion Starter #12
I know! I was simply teasing [:D] and know about all that stuff about the CAI, etc. I guess I should have been more clear...

266,000 miles? I thought you had a rebuilt engine?

My speedo is optimistic by 10mph [:D] and I still have yet to cure its flickering when at low speeds. New one needed or perhaps just not tight enough? I know the speedo is mechanical, correct?
 

·
Registered
1982 300D Turbo
Joined
·
457 Posts
im not sure, ill check. ya i have at 200,000 miles i got a rebuilt engine so it has 66,000 miles on it. now i think the turbo seals are bad cus its using oil like mad, but im changin the turbo housing on it within the month, yippee, should be an all day job but hopefully no more leaking. maybe more boost than 10 pounds too [:)]
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Discussion Starter #14
Turbo seal? You mean the turbo drain seal on the right side of the engine, under the turbo, near the alternator?

Mine has a small leak too but I never see the oil go really low, even when I'm near an oil change (usually after 3000 miles) that's odd...
 

·
Registered
1982 300D Turbo
Joined
·
457 Posts
I ment the turbo has internal leakage. Becuase it cant be the rings that are leaking due to a recently rebuilt engine, unless the guy used cheap rings, but we asked and he didnt. So its gotta be the turbo. we will see cus my dad found a spare turbo so we will switch just the turbine side and keep the compressor side. Get it, Got it, Good! [|)]
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Discussion Starter #16
Sounds like you got it under control. But I just have to say, I don't usually hear of a turbo seal going bad. If it is, then I'm glad you found the source. I think I've heard of stories about runaway diesels because there was oil in the turbo or something...?

Hey my car still shudders when I warm start it, but only when my EGR is capped. I wonder why. Too much fuel or air? Anybody?
 

·
Registered
1982 300D Turbo
Joined
·
457 Posts
take a pic of how u did your egr, capped it.
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Discussion Starter #18
I basically removed the rubber vacuum tube from the EGR and capped it with a screw. The EGR now has an open hole on it and the vacuum line I disconnected just hangs with the screw cap. I'll test my car tomorrow with the rubber vacuum line (that's capped) connected to the EGR instead.
 
A

·
Guest
Joined
·
0 Posts
hey obaja, u really wanna race, then get that kit like i got....heh heh. it helps immensely![}:)][}:)]
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Discussion Starter #20
Ok so I transferred the dangling rubber vacuum line w/screw to the EGR. The EGR is now capped. There was minimal shaking when I hot started the engine. I guess this does it. No other differences noticed except a larger smile stuck on my face [:D]
 
1 - 20 of 23 Posts
Top