Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #1
My 1987 260E has a rough idle. It idles at 700-750 rpm and sometimes it idles rough like it's misfireing. The car has 200,000km.
I have changed the plugs, wires, cap, rotor, fuel filter and cleaned the throttle body but still nothing! Can anyone give me some advice, maybe I'm missing something???
 

·
Registered
'80 450SLC Afro RHD Ikonengold
Joined
·
2,863 Posts
Why not doing tuneup first?
Check CO2, injectors, if not a big problem check Cam lobes for wear (just under the cover and a few screws out).
Actualy check for vacuum leaks first.

Good luck hunting...
 

·
Registered
1991 300 SE
Joined
·
18,534 Posts
High idle:

The Idle Control Valve can fail or become dirty (sticking). A long soak (24 hours) in brake or carb cleaner may solve the problem. Otherwise the valve will have to be replaced.

When the idle control valve is ruled out move on to the following:

Idle Control Unit – located under the dash either in the middle or near the steering wheel shaft (the location is different in each model, but all are inside under the dash) – is an electronic relay which is replaced (resoldering is also possible).

Throttle Position Switch – replace, worn or broken terminals.

OVP Relay – located on the second firewall near the fuse box.

Worn Injectors or Leaking Injectors.

Broken/brittle/missing/disconnected vacuum hose(s).

Rough idle:

The EHA/Fuel Distributor may be dirty, leaking, or not getting current:

http://www.thebenzbin.com/mercedes-gas-smell.html

Spark Plugs or Wires may need to be replaced.

Vacuum Hoses cracked or leaking.

Faulty CIS Coolant Temperature Sensor.

Failed O2 Sensor.
 

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #4
I pulled the fuse out of the ovp relay and the car
ran worst!
When I purchased the car 1 month ago it was running like this(rough at idle).
The lady who owned the car replaced the alternator and the battery! I'm wondering if she had the car boosted at that time! Maybe she fried something ?
 

·
Registered
1991 300 SE
Joined
·
18,534 Posts
Don’t pull the fuse out of the OVP relay – when you put it back did it run better? I’d start with the idle control valve and give it a good 24 hour soak.
 

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #6
I cleaned the contacts on the OVP and the socket it goes into! There is a better difference and tonight I'll soak the idle control valve! I'm going to get some fuel injector cleaner too!
thank you,
p.s. Send a little bit of sun up north will you !
-3 in Toronto today!!
 
1 - 6 of 6 Posts
Top