Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
'85 500SEL AMG, 91 560SEL, '99 E55, '00 SL600, '99 S600, '99 E300 TD, '92 190E
Joined
·
183 Posts
Discussion Starter · #1 ·
Driving home last night I overtaked a C230 Kompressor, some young kids were driving it...running head to head at 65 mph, we both punched it and I only beat him by half a car length. I let out at 120 mph...so, from 65 to 120, the C230 was barely slower than me.

My car is a 1999 E55, driving it in S mode. All service is up to date (plugs, filters, etc.), no secondary cats and has X-pipe mod. The car has 150,000 miles. I am second owner, lady driven, no abuse.

Is my car wore-out? That is very poor performance.

Do you think the MAF is bad? What can I check or do to regain some power?

Hyder
 

·
Registered
Joined
·
8 Posts
Driving home last night I overtaked a C230 Kompressor, some young kids were driving it...running head to head at 65 mph, we both punched it and I only beat him by half a car length. I let out at 120 mph...so, from 65 to 120, the C230 was barely slower than me.

My car is a 1999 E55, driving it in S mode. All service is up to date (plugs, filters, etc.), no secondary cats and has X-pipe mod. The car has 150,000 miles. I am second owner, lady driven, no abuse.

Is my car wore-out? That is very poor performance.

Do you think the MAF is bad? What can I check or do to regain some power?

Hyder

A few suggestions
*Reset the Tranny logic
*Run an OBDII scanner to look for any old codes.
*Check your compression.....Does the car start right up in the morning? Any smoke from the tail pipe first thing in the morning?

Best would to get on a dyno with a wideband 02 to check things out, or find a G-tech pro and do a couple of runs.

Many factors can affect a race, was that c230 really stock? Maybe they installed a smaller pully for more boost. This could be a long shot but maybe they had a c43,c32,c36 and put the body kit on from a c230 and badge and love tricking people.

It would be nice to have a 211 chassis e63 and put the kit, badges and wheels on from a e350(maybe e550 wheels for traction) and clean up at the dragstrip for fun.
 

·
Registered
2000 E55 AMG
Joined
·
577 Posts
My first impression is a worn MAF sensor. Unfortunately, you will not get codes 0170;0173 until the dang thing goes kaput. If you are running with the original MAF sensor, then by all means, apply a new one. Your buttometer will thank you for it. Another item that comes to mind, and forgotten by many, is the fuel filter. Just more food for thought. Good luck.
 

·
Registered
2001 E55
Joined
·
117 Posts
Did you try an ECU reset? Also, have you been switching from "w" (wet mode) to "S" while driving? In the manual it says doing this while driving could impair your vehicles performance. Try the ECU reset first. Then while in PARK, with the car running, switch to "W" then wait a minute and switch back to "S". Do not take the car out of park and keep it running the whole time. Now drive and see if you notice any difference? I did this and an ECU reset and things got better for me. Let me know what happens. Brian
 

·
Registered
'85 500SEL AMG, 91 560SEL, '99 E55, '00 SL600, '99 S600, '99 E300 TD, '92 190E
Joined
·
183 Posts
Discussion Starter · #5 ·
Thanks for the replies..i am out of town, but I will change the fuel filter and MAS. The MAS is original. The C230 was about an 2005 and I am positive it was stock.

Also, the car starts right up, but if it sits for more than two weeks without starting, it will blow out a small white smoke puff, maybe last two seconds.
 

·
Registered
Joined
·
483 Posts
Well the 2005 C230 isnt too terribly slow believe it or not. When I drove one you could shift down to 3rd and really take off its torquey little thing and it weighs less than 3300 lbs. I got it to go 0-60 in 7secs, which is 1.5 seconds slower than our cars but that was from a dig.

Replace your MAF, and also, stomp on the gas pedal. dont push it to get this beast up and going it needs to be stomped on.
 

·
Registered
2001 E55 AMG, 1985 380 SL
Joined
·
107 Posts
I beat a CLS550 from stand still by a car's lenght not too long ago in my 01. I'd look into MAFS for sure!
 

·
Registered
2000 E55
Joined
·
292 Posts
I beat a CLS550 from stand still by a car's lenght not too long ago in my 01. I'd look into MAFS for sure!

Yeah I've read post where E550 people think thier car is faster than than the W210 E55. What they forget to take into account is the 600lbs they have on us and the Most important..the 2:5X:1 axel ratio compared to our 2:7X:1...they have a few more horses...but we have the same tq. A CLS is even heavier than an E.

Jim
 
1 - 9 of 9 Posts
Top