Mercedes-Benz Forum banner

1 - 13 of 13 Posts

·
Registered
2004 (w220) S500 & (R230) SL550 2007
Joined
·
629 Posts
Discussion Starter #1
Drove home fine yesterday, today all of a sudden no starter not even a click . Dash lights up normal and both batteries 12+ volts.
Shifter shows P or N when moved, foot on brake, key or keyless, starter does nothing.
Disconnected both batteries & after 1 minute reconnected no change. I'm out of ideas...
 

·
Registered
2011 SL550 Black
Joined
·
31 Posts
This very thing happened to me and I had to have it towed to the dealer. After starter replacement all was good. There must be better ways to find out it's a starter. Maybe someone else on the forum can assist.

Good Luck
 

·
Outstanding Contributor
'03 SL500, '03 SL55, '97 SL320, (2) '91 300SL, (2) '91 500SL, '00 S500 -- all for sale
Joined
·
4,173 Posts
This problem seems to come up several times a year. It could be a faulty ignition switch, starter relay, starter, or engine management controller.

I'd first discern whether or not the starter relay is energizing when the ignition key is turned. The starter relay is among several relays in the passenger-side fuse box. You can tell if it is energizing by listening for an audible "click".

If the relay is energizing, next I would check the voltage on the starter motor; if it isn't, then I would check the I'd first discern whether or not the starter relay is energizing when the ignition key is turned. The starter relay is among several relays in the passenger-side fuse box. You can tell if it is energizing by listening for an audible "click".

If the relay is energizing, next I would check the voltage on the starter motor; if it isn't, then I would suspect the ignition switch and investigate further with Star Diagnosis.
 

·
Registered
'01 W163 ML430; '04 SL500; '05 E500; 05 E320 Wagon 4-matic
Joined
·
3 Posts
Have you tried to jump the car with another battery?
My SL did something similar. I drove from the house to a store down the street, and minutes later it would not start, stranding me - sort of. I walked home and drove another car back to the store and tried to jump the SL. It started right up. The starter battery measured 12 Volts, but was apparently old enough not to provide sufficient current. These cars are really picky about voltage levels and current capacity. I bought another battery at Advanced Auto (they actually had it in stock and it appears to be a unique battery to this car - I think it was about $150). Have not had a start issue since. I have since had to replace that plastic piece of junk lock-bar in the shifter though.
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
18,940 Posts
I'd start (no pun intended) at thee starter. Check to see of the solenoid gets voltage when the key is turned. If so, then it's a bad starter. If no voltage is present, then start working your way back to the relay and fuse.
 

·
Registered
2003 sl55amg
Joined
·
66 Posts
OK, this may sound a little crazy. I worked as a tow truck driver between careers long ago, and we would get all sorts of calls including "no start". Before we were allowed to tow a vehicle we had to follow these steps.
1. Try to jump start. We had these really heavy cables that would work when cheap ones would not.
2. Check and clean the battery connections, and try again.
3. Bang on the starter motor with a hammer. This worked most of the time. Customers would ask if it was fixed. The answer was, it may start for years, or never again. Get a new starter.
 

·
Registered
2004 (w220) S500 & (R230) SL550 2007
Joined
·
629 Posts
Discussion Starter #7
why are there no instructions on removing the starter for an R230 ?
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
18,940 Posts
There are instructions - you just need to have them. WIS is what you want. It comes with SDS, which you will eventually need to DIY on this car. If not, you can get WIS as a stand alone on eBay for under $30. If your car is a V8 (Sl500 or SL550) it's a very easy process and a typical starter replacement job: disconnect the batteries (rear first, then front) the lift the car, remove the lower engine covers for access, remove the electrical wiring, then unbolt and remove the starter.
 

·
Registered
Joined
·
10 Posts
I’m having this same issue or rather sumn similar to it. I Recently changed my spark plugs and wires and try to start the car and no click, tried about 8 more times and the car went blank( no instrument cluster Christmas lights or anything but my key went all the way to position 2 and still no start or click so I charged the batteries and that didn’t help...anyway I knew it had to be a fuse or something so I went poking around and checked all my fuses and none of them were burnt...then I pull the passenger floor well area up and the prefuse fuses were there checked the module and found discontinuity to N73 ..fuse was blown on the inside of it ..changed it (this may be the solution to your issue) but as soon as I go to start the car I see SRS light and THE roof bar light so I get happy and keep going and click damn fuse blows again....I go check all the various things I had hooked up in the car eg aftermarket Bluetooth etc and install a new fuse and attempt to start again and pop goes the fuse again...ordered 2 more fuses inspected everything that I can see and checked the harnesses and installed another fuse 80a midi fuse again and POP....at this point I’m fed up I’ve been tackling this for 4 days now and still haven’t found the culprit..the fuse doesn’t blow till I attempt to start the car
 

·
Outstanding Contributor
'03 SL500, '03 SL55, '97 SL320, (2) '91 300SL, (2) '91 500SL, '00 S500 -- all for sale
Joined
·
4,173 Posts
...I get happy and keep going and click damn fuse blows again.
Perhaps a defective N73 could short to ground and blow the fuse, but I'd guess it is a load served by N73. It would be helpful to know in which key position the fuse blows -- 1, 2, or 3.

I suggest you start a new topic of your own and title it "Pre-fuse blows when key turned" or something, since your problem is different from poptopclk's. Also, if poptop starts posting back here it gets messy responding to two different people with different problems.
 

·
Registered
2004 (w220) S500 & (R230) SL550 2007
Joined
·
629 Posts
Discussion Starter #11
It is DEFINITELY the starter and i removed all the under panels and when ignition is turned to start there is a 12 volt reading a starter terminal.

THE PROBLEM IS HOW DO YOU GET THE 2 BOLTS OUT that hold the starter in? There is almost no room at the bottom and the top bolt seems totally impossible !

Really bad design, a starter should be easier to get at !!
 

·
Registered
Joined
·
10 Posts
Perhaps a defective N73 could short to ground and blow the fuse, but I'd guess it is a load served by N73. It would be helpful to know in which key position the fuse blows -- 1, 2, or 3.

I suggest you start a new topic of your own and title it "Pre-fuse blows when key turned" or something, since your problem is different from poptopclk's. Also, if poptop starts posting back here it gets messy responding to two different people with different problems.
@bobterry99 hey thanks for the input that’s similar to what I was thinking @poptopclk mybad for hijacking your thread
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
18,940 Posts
1 - 13 of 13 Posts
Top