Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
S500 | 220.175 | 113.960
Joined
·
363 Posts
Discussion Starter #1
SYMPTOMS
1) drivers door only - if I use soft close, the door sucks in half way, is released, then trunk pops open, then the door closes/sucks in completely.

2) Randomly, while standing still or rolling <5mph (no matter of gear) , all doors are squeezed by the soft close system, then trunk pops open

3) 1 and 2 were intermittent problems until recently, now this happens non stop

Suspecting water damage i took out circuit board for window regulators, window lock and trunk open. I did have some residue on the contacts. It even appeared to me the problem was happening exactly when i was cleaning the contacts on that board and shorting some perhaps. But after slight clean there is no change. There is one other central board in the door which unites all components together (i think its behind the seat button panel) Is water damage common there?


Now the trunk harness which retracts into the trunk,
Can it really do all of this? With the door squeeze and trunk opening?


By the way, the trunk stays shut when moving >5mph or when car is locked.



Wow s class is too water sensitive. The tons of money into development, but what about water!!!
 

·
W221 & Audio Moderator
2013 S550
Joined
·
10,978 Posts
As I understand it, the PSE pump has a fairly complex system for directing pressure to the proper places; my guess would be that somehow that sequencer has gotten screwed up. I don't know much more about the problem, but I do recall some discussion of it about 2 years ago.
 

·
Registered
S500 | 220.175 | 113.960
Joined
·
363 Posts
Discussion Starter #3
Can you please tell me is the PSE pump on left or right side of trunk carpet lining. I imagine it should be tucked in above one of rear wheels somewhere?.... or...



Unfortunately a problem like this is hard to diagnose, as i umderstand the pump itself is quite high price, i hope i find some tips on here, thank you for the first Skylaw!
 

·
Registered
S500 | 220.175 | 113.960
Joined
·
363 Posts
Discussion Starter #5 (Edited)
So far I had to disconnect both connectors from the trunk latch itself to stop it from opening endlessly, though there were days when the whole system worked normally. I can still open the trunk manually (bc latch is mechanically connected to the key/button mechanism, but I also still hear doors squeezing now and then.

I am determined to get to pse pump. I am also looking for pse pump fuse? I see in diagram fuses for central locking/trunk release and the locks, most are under rear seat, but the way the little ones are positioned a piece of frame is in the way of getting them out.

Can someone pls tell me if seat needs to be lifted to acess the smaller fuses that are at the top of rear fuse panel

Ty!
 

·
Registered
S500 | 220.175 | 113.960
Joined
·
363 Posts
Discussion Starter #7
I heard from an acquaintance of mine, that his CL600 had the same problem. He ended up taking it to the dealer and having to pay a few hundred for a software glitch repair.
Lol!

Okay, then maybe I can resolve this issue with my service guys star laptop.

You guys wouldnt believe this they have non stop flow of car repairs, they have the bmw and mercedes computers but they cant even use them. So i end up using it instead.

But this problem im having really requires some pro diag
 
1 - 7 of 7 Posts
Top