Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter #1
has any had a problem with their akebono brake pads screaming when the weather is cold? these pads work great during the summer and when they have some heat in them, but when I am in stop and go traffic in the cold, usually 60 degrees or lower, they scream like I just kicked the dog! Is there a cure or do i need to go back to EBC red stuff? thanks for any input......:surrender:
 

·
Registered
2000 S430 156k (11/12)
Joined
·
507 Posts
What year is your car? Do you have Akebone in both front and rear? Do you have the original rotors installed or some aftermarket rotors? Is the noise coming from the front or the rear?
Check first to make sure you're not dragging your dog around.
So, you do kick your dog?
 

·
Registered
Joined
·
123 Posts
Discussion Starter #3
akebono brakes all around, squeals from the front, original rotors, 2001 and usually kick the dog on Mondays after football game...
 

·
Registered
Joined
·
373 Posts
Most likely they will scream when you first start your vehicle because there is rust on the rotors? Mines do that too when its cold and there is alot of condensation in the fall/winter.
 

·
Registered
Joined
·
34 Posts
Change the rotors. I have found that the originals can't handle the ceramic pads. I use zimmermans coated. They work great and don't rust. Also sand down some of the pad as a shinny mark will also make this come back. Good luck
 

·
Registered
2000 S430 156k (11/12)
Joined
·
507 Posts
Some early models did have this problem mostly while backing up and there is a kit to remedy the problem.

Piston vibration damper 0004210147
 
1 - 6 of 6 Posts
Top