Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I recently bought a 2011 S550 4Matic and it looks like there are some Airmatic issues that need to be addressed.

Behavior:
  • Front left wheel sinks completely about 15 minutes after parked (strut has been replaced)
  • After I start the car, the FL wheel is raised up to -0.7 inches and the FR wheel is raised to about +1.6 inches
  • If I press the button to raise the suspension, the FL goes to 0 inches and the FR raises to 2.8 inhes
I replaced the FL strut with an Arnott strut, thinking that an air bladder was leaking, but the same issue persists. I'm thinking that the lowering FL wheel may be due to a leak in the line or the valve body (which I'll investigate soon).

As for the car not correcting it's level, I have no idea why this would happen and could use some advice. I'm reading level sensors via an iCarsoft MBII scanner and they appear to be working properly. The car switches on the compressor, the pressure sensor records about 14 bar as the struts are filled with air, but it just stops raising the car after it gets to this odd, lopsided position.

Thank you!
 

·
Registered
Joined
·
130 Posts
I think the issue is the ride height sensor that went bad. It has an arm and electrical connector. It is located in the wheel well. Start by cleaning the connector. See attached photo:
2602157
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4
The issue turned out to be a very slight crack where the air line connected to the fitting on the valve block. Trimming off the defective inch and reinstalling the line fixed the problem.
 
1 - 4 of 4 Posts
Top