Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
1981 240D
Joined
·
95 Posts
Discussion Starter #1
On Thanksgiving Day, I couldn't get Geraldine started-she just cranked, and blew white smoke. Not at all normal behavior. Owing to a busy work schedule, I had to leave her till today, when a friend and I were able to get her started (with considerable difficulty). My friend thought that there were two factors at work-air in the fuel system, and a positive battery cable in less than perfect health. He has experience working on diesels, but not on Mercedes, and he could not say how the air was getting in. I have a suspicion that one of the injectors may be leaking. Is that a likely cause of this kind of trouble? It seems to me that since we got her started, the idle is inordinately rough. Is this another manifestation of air in the system, and/or fuel injector malfunction? Any helpful suggestions will be greatly appreciated.
 

·
Registered
'86 W123 200, OM617 non-turbo, bastard 5-speed; '95 W202 C250 Diesel, OM605 non-turbo, 5-spd man
Joined
·
4,151 Posts
Rough idling could certainly be caused by air in the system or faulty injectors. My W202's OM605 has the same problem. However, I can honestly say that my W123's OM617 has never had air in the system after being primed, usually following a diesel filter replacement. I couldn't say where the air comes in.
 

·
Registered
1984 300TD
Joined
·
110 Posts
Check the fuel supply hose clamps. Those fuel pumps can suck like crazy. I saw a photo once of a W123 fuel tank that was crushed like an aluminum beer can because the vent system did not permit air into the tank, but the lift pump pulled the fuel out of it anyway. So, make sure the fuel tank venting is operating normally. Air bubbles in diesel fuel will cause tailpipe smoke also. And it will suck in air at incompetent hose clamps.
 

·
Registered
1982 300d four speed turbo & 1984 300d four speed N/A euro
Joined
·
338 Posts
Sounds fuel related yeah, but instead of air in the lines it could simply be clogged somewhere within one of the filters. I'd probably start there unless you can locate a visual leak
 

·
Registered
1983 240d
Joined
·
48 Posts
Not an expert, but I would concur with air in the fuel lines. First check your fuel filters, and replace if necessary. The inline filter is a good way to actually see if air is getting in, the fuel level in the clear filter will be low. A clogged filter is in my experience the most common cause. Check all the rubber lines going back to the tank (and especially the 2 which attach to the tank under the car). Anywhere that looks wet is letting fuel out, and air in. If any of these hoses are original, they could be degrading. Make sure the connections are tight. Another possibility is water in fuel, if, for example it sat through a dramatic temperature change as is common this time of year. Finally bad fuel will do this as well. If you bought diesel from a place without much traffic, where you normally don't, that could also be the cause. Injectors would not be my first location to check, and especially if they appear dry around the base and threaded connections.
 

·
Registered
1984 300D
Joined
·
5,068 Posts
Concerning an air leak of the most notorious source of air leaks is the old style Hand Primer. The older Hand Primer has a shiny aluminum body and a hard plastic knob that is usually white but I have seen some that are black or brown. That is especially true if when you use the Hand Primer it leaks Fuel.
Replace it with a newer style Bosch Hand Primer.
I don’t recall what year your 240D is but if it is one from the 1980’a replace the 2 sections of fuel inlet hoses. On mine I had an air leak there because the hose was too hard and inelastic to seal.
 

·
Registered
1981 240D
Joined
·
95 Posts
Discussion Starter #7
Thanks to everyone who responded. I had Geraldine checked out by a mechanic who has worked on her before. He tightened up some of the injector lines, and now the idle is much smoother. (She still tends to misfire on a cold start, which has be going on for a while). Incidentally, I had fueled up (at one of my usual places) just two days before the initial failure to start, and at the same time, the weather had made a dramatic change, from very dry to damp and rainy, which it has been, to some degree, ever since. Whether there is any possible connection, I do not know.
 
1 - 7 of 7 Posts
Top