Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1990 300SE, 1983 300D
Joined
·
1,201 Posts
Discussion Starter #1
This happened to me yesterday. A few times actually. Its like the car has no power. I nail it, and it doesnt go past 3,000. I drop it into S, nail it, and still nothing. Its like the car doesnt want to move. I mean, its moving, but hardly. I went to go get some gas, so I turned the car off for 10 mins while I was filling up. When I started it back up, the car just took off. And this happened other times too when I had gas. Can that diesel purge stuff help? I dont really know what it does. Any advice would be apperiated.
 

·
Registered
Joined
·
483 Posts
I don't quite get how doing the Diesel Purge directly, so I just poured it into the tank. It does help. Car seemed faster when my tank was nearly empty.
 

·
Registered
1984 300D Turbo
Joined
·
1,606 Posts
1985 300CD - 2/27/2005 12:08 PM

This happened to me yesterday. A few times actually. Its like the car has no power. I nail it, and it doesnt go past 3,000. I drop it into S, nail it, and still nothing. Its like the car doesnt want to move. I mean, its moving, but hardly. I went to go get some gas, so I turned the car off for 10 mins while I was filling up. When I started it back up, the car just took off. And this happened other times too when I had gas. Can that diesel purge stuff help? I dont really know what it does. Any advice would be apperiated.

engine was warmed up when the no power thing happened i'm assuming..

maybe your tank vent is clogged.
next time when it does that turn the engine off and go around and open the fuel cap. if you hear a''whoosh'' it means there is vaccum built up in the tank and you need to clear the vent.
sorta the same feeling as air in the lines.
 

·
Registered
1990 300SE, 1983 300D
Joined
·
1,201 Posts
Discussion Starter #4
84300DTurbo - 2/27/2005 2:24 PM

1985 300CD - 2/27/2005 12:08 PM

This happened to me yesterday. A few times actually. Its like the car has no power. I nail it, and it doesnt go past 3,000. I drop it into S, nail it, and still nothing. Its like the car doesnt want to move. I mean, its moving, but hardly. I went to go get some gas, so I turned the car off for 10 mins while I was filling up. When I started it back up, the car just took off. And this happened other times too when I had gas. Can that diesel purge stuff help? I dont really know what it does. Any advice would be apperiated.

engine was warmed up when the no power thing happened i'm assuming..

maybe your tank vent is clogged.
next time when it does that turn the engine off and go around and open the fuel cap. if you hear a''whoosh'' it means there is vaccum built up in the tank and you need to clear the vent.
sorta the same feeling as air in the lines.
Engine was warm. I dont know what was up. I put some Diesel stuff in the tank today. Been acting good. Dident happen. Also, how hard is your gas pedal. My pedal is kinda hard. Dont know if its normal or not.
 

·
Registered
G320 & E500
Joined
·
1,193 Posts
Schmohey - 2/27/2005 1:40 PM

I don't quite get how doing the Diesel Purge directly, so I just poured it into the tank. It does help. Car seemed faster when my tank was nearly empty.
[:D][:D][:D][:D][:D][:D]
If you poured Diesel Purge directly into the fuel tank, you virtually wasted it.
In order to run Diesel Purge, you have to run the engine it in a pure state. You have to recycle the return lines directly back to the Diesel Purge tank.
Otherwise the return lines will take it right back to the main fuel tank.
The engine should run for about 10-20 minutes before actually burning through the entire 1 Quart bottle.

Here is a GREAT LINK!
http://www.mindspring.com/~houlihan/merc/purge.htm

Chuck
 
1 - 5 of 5 Posts
Top