Mercedes-Benz Forum banner
1 - 3 of 3 Posts

· Registered
Current: '14 S550, '99 S500, '10 Prius; Previous: '93 400SEL, '98 Corolla
Joined
·
105 Posts
Discussion Starter · #1 ·
My air conditioner ('93 400SEL) has stopped blowing cool air. It had some intermittent problems (blowing warm air) last week and it worsened today and totally stopped blowing cool air. The fan seems to be working and it's blowing air, but the air is HOT. Unfortunately, the summer is getting pretty hot and it is difficult driving a car without an A/C. The previous owner had said he had the A/C evaporator work done and it had been quite expensive. I'm just surprised that the A/C should begin causing problems again. Does anyone have any ideas?? Any help would be appreciated before I go to a mechanic and hear how much $$$ it's going to cost to get this repaired.
 

· Registered
92 500SEL to 01 E320T current 2014 lexus LS460
Joined
·
3,885 Posts
A/C diagnostics

Check out this page http://pages.prodigy.net/jforgione/MB_S500.html
it is not a hyperlink paste it into your browser, and look at #15
I guess I did paste it as a Hyperlink, otherwise do it manually
 

· Registered
Current: '14 S550, '99 S500, '10 Prius; Previous: '93 400SEL, '98 Corolla
Joined
·
105 Posts
Discussion Starter · #3 ·
Thanks

I got it fixed. It was just a broken wire to the compressor. A $126 problem! Just labor and a bit of Freon. Nothing else and now it's cool again! What a difference an airconditioned cabin makes:)
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top