Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Please offer any advice as I dearly love this van but can no longer live with this stupid problem
Hi all Sorry to hit you all with a query I have 2001 vito cdi ,van cuts out under heavy load around 3200rpm each time ,edc light comes on van cuts out ,but starts right back up again and edc light goes off ,codes logged are P1187 , Van has always need 2 or 3 seconds to crank before starting as if fuels dropping back or its having to build pressure up in system before it will start and it will do this even if upto temp switched off then back on again, I have replaced o rings on right side sensor ,van has only 108k with a full merc history Also not sure if relevant but if you floor it and lift off in high gears you can hear a whooshing noise oh and it rattles top end when accelerating so no idea if this is normal Had smoke test done on intercooler side to check for leaks and leak off test done aprox 6mths ago both tests came back normal ,really want to keep this van and have a wealth of spares for it as I break vitos sometimes so have pretty much 2 of everything Please help Michael
 

·
Registered
1 x 190e, 2 x vito cdi 110 many spares....
Joined
·
9 Posts
how are ya ,
might be a bit late , the code is rail pressure monitior, the thing that lives on the end of the common rail line below # 4 on your left looking at the front of the vehicle it will cause the edc light to illuminate also check injectors as and the wiring.... with the vehicle not going above 3000 rpm your in limp mode ... ie get you to repair shop
solution replace pressure sensor, or put a kit through it ** check the plugs and wiring to that and to injectors **

the wooshing is an air leak in the pressure side of the turbo chargind system ie turbo to intercooler , cooler to intake , intake to engine
vehicle must be gutless?

ticking sound .... not sure

hope it helps cheers
chris
in NZ :)

let me know how far off i was?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
how are ya ,
might be a bit late , the code is rail pressure monitior, the thing that lives on the end of the common rail line below # 4 on your left looking at the front of the vehicle it will cause the edc light to illuminate also check injectors as and the wiring.... with the vehicle not going above 3000 rpm your in limp mode ... ie get you to repair shop
solution replace pressure sensor, or put a kit through it ** check the plugs and wiring to that and to injectors **

the wooshing is an air leak in the pressure side of the turbo chargind system ie turbo to intercooler , cooler to intake , intake to engine
vehicle must be gutless?

ticking sound .... not sure

hope it helps cheers
chris
in NZ :)

let me know how far off i was?
Hello Chris
Many thanks for taking time to help
I have replaced the left side pressure sensor on the rail and still the same problem
Not checked wiring on injectors but I have a loom here if it is needed so will check this asap
As for leak on intercooler side I have had a pressurised smoke test done and it showed no leaks about 1 year ago
Gutless erm no van seems to go very well just dare not put foot down to overtake etc
I would not mind if the fecking thing went into limp mode but it cuts out and dies on you each time which canny shits you up when inthe outside lane of the motorway overtaking and it dies haha
 
1 - 4 of 4 Posts
Top