Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
2001 Mercedes-Benz ML320
Joined
·
27 Posts
Discussion Starter #1
I purchased the car already upgraded to (probably) the ebay headlights. I'm not sure what kind these are but the bulbs produce a light blue color. It started when the car was cold and I put the lights on, the one wouldn't work. So I would turn them off and back on and then it would work. Then they would flash a little until the car warmed up. Now it looks like the right headlight bulb is out (the rest of the headlight still works). And the left one will go off when I'm driving sometimes and come back on. Went to pepboys to buy new bulbs and the guy said it probably isn't the bulbs that need to be replaced. So now I'm confused? Anyone else have this problem? Thanks.

-Don
 

·
Registered
2001 Mercedes-Benz ML320
Joined
·
27 Posts
Discussion Starter #2
Researched a bit more and it's probably the ballast because I had that flickering problem. Anyone know the best cheapest place to buy this? I'm really getting frustrated with the ML. Just had the cat replaced, needs o2 sensors, rear shocks and springs, fuel pump, and now this. TRYING TO STAY POSITIVE.
 

·
Registered
Dallas, Texas
Joined
·
7,702 Posts
Google search with "mercedes ml hid kit" returns 1,520,000 hits.

Which one do you have?
 

·
Registered
Silver-2002-163 Sold
Joined
·
56 Posts
Hey "donz",
It seems to me that you have an aftermarket Headlight assembly that came with or has a Xenon/HID kit installed on it…
I actually experienced the same problem...I'm here in Canada and 3 weeks ago it was about -17C with the car parked outside for 3 days...my xenon light/kit wasn't as bright and did not turn “on” for a few minutes ...after about 30min of warm up (lights being on with the car running) the problem went away… other time I experienced it while i was driving (still because of extreme cold)....I hit the break suddenly and due to the sudden shake (for some odd reason) I realized my light just came back on... However I don’t think it will get that cold in Philadelphia….so your problem could be more of a technical (hence your Xenon Kit previously installed on your ML is at the end of its life [They usually last about 2-3 years-if always on]
My situation: Ever since the cold has died out...the lights have been fine...
I purchased my HID/Xenon kit over eBay… "55W(brightness), 6000K (color), H7 (bulb fitting for ML) "
I've been very content with my Kit…and they usually costs anywhere from ($45-$120+) [I don’t necessarily guarantee that the more expensive ones $200 is any better…Since they are mostly assembled and made in China- their technology is really easy to produce and simple…

***One thing to note....The HID KIT once installed on a stock (non-Xenon/regular halogen W163 headlight) WILL NOT WORK... when the car is off it works, once you turn the car on/turn the engine on it blinks and shuts off... Something to do with the ML's computer... The shop that did it for me placed a capacitor of some sort for each headlight and I was good to go! :)

***However I am not sure about the after-market headlights for the ML that already come with a Xenon kit...I am assuming since your car already came with it, it should be fine. (meaning the capacitor is already connected to make it work, hence its there)

***I would suggest you to see if the "Xenon/HID kit" installed on the headlights are continuously still makes the problem of not working/ blinking/ shutting off. Then do a little research and see if you can change both the ballast and the light bulbs (since they are all literally connected together [most of them]-meaning the wires are all connected so it’s not separate) with a new one ordered from eBay. You need to know how to do this properly (taking out your headlight assembly and changing the "HID Kit". In my opinion it's very easy but if you have never taken them out you have to do some research and then proceed... Otherwise...
**** if you don't have the time, just take it to a shop "And not pep-boys" ask around for shops that do mods or after-market installations they will take care of your problem...(I am assuming it will cost you more but worth it)…

Good luck :)
 

·
Registered
Silver-2002-163 Sold
Joined
·
56 Posts
I’m not sure about Aftermarket headlights but if the HID kit is not hardwired literally inside the headlight assembly….IF NOT (check your headlights)…then:
Not 100% sure if this could work….but…For temporary, or if you are truly fed up just get the regular “H7” halogen light-bulbs from your Mercedes dealer or Pep-boys since they have a variety of after-market Halogen bulbs.
****This is going to be the Cheapest and most reliable option…but no Xenon!
Just take out your headlights completely remove them take the HID kit out of it…and go back to the regular H7 bulbs…..plug it in and you should be good to go: but again do your research…
Best wishes
 

·
Registered
2001 Mercedes-Benz ML320
Joined
·
27 Posts
Discussion Starter #6
Thanks so much for your detailed help. I really appreciate it! I'm taking it to the shop tomorrow most likely (for something else). I'm going to ask him to check the lights to make sure, but I'm pretty sure it's the ballasts and bulbs. Found this on ebay which I think is what your talking about:

Xenon HID 6000K Conversion Kit Mercedes ML Class 02-08 - eBay (item 350358596091 end time Dec-20-10 22:39:28 PST)

I found directions on how to do it, but maybe it's worth paying a few bucks to get it done.
 

·
Registered
05 ML500 SE
Joined
·
1,482 Posts
A kit that several forum members have installed and had great success with is made by DDM tuning. I am running h7 55W 5000k and the lights are really bright. Anyway I highly recommend them. :)
 

·
Registered
Joined
·
2 Posts
Hi guys,
I've a ML270 CDI and I've tried to install xenon on it... and it happened what borna was saying...

"***One thing to note....The HID KIT once installed on a stock (non-Xenon/regular halogen W163 headlight) WILL NOT WORK... when the car is off it works, once you turn the car on/turn the engine on it blinks and shuts off... "

Is there a specific HID Conversion KIT for ML?
 

·
Registered
Silver-2002-163 Sold
Joined
·
56 Posts
There is a capacitor that goes in between the plug-ins. Most shops that do customizing should have this. Hope this helped.
 

·
Registered
Joined
·
2 Posts
Hello,

I've already tried that procedure, putting a capacitor between the plug-ins and got no sucess :mad:

What about a CAN-BUS kit? It may be a solution for this problem?
 

·
Registered
Silver-2002-163 Sold
Joined
·
56 Posts
Hello,

I've already tried that procedure, putting a capacitor between the plug-ins and got no sucess :mad:

What about a CAN-BUS kit? It may be a solution for this problem?
I think the CANBUS kit is the same thing " essentially they are all some sort of capacitor which tricks the cars, thinking nothing unusual happened (with the Headlight wiring)"

This is what you are looking for: (These kits don't work on all vehicles) do your research before buying- make sure they have a return policy)
http://www.hidxenonlights.com/wiring-upgrades-c-667/hid-flickering-eliminator-plugs-p-201
http://www.kbcarstuff.com/CANBUS-Fix-p/cbfix.htm

Before spending any money online you should just take the ML to a a shop that does custom projects on European cars, and you'll definitely have it running! Its not worth getting frustrated over it.. :) Buying a kit online and then having it not work...etc..

If you have the HID Kit installed inside the headlight properly, adding the Capacitor will allow it to function when the ML's engine is running!

Here is my setup...
 

Attachments

1 - 11 of 11 Posts
Top