Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
300 SEL (1989)
Joined
·
369 Posts
Discussion Starter #1
Having problems with the airconditioning of late.
Often the A/C clutch won't engage & in our 92F temperature, life becomes miserable. The next day the A/C works fine (cold).
Any advice on wiring the A/C clutch direct?

Garage screwed up the ABS. They burnt out the control box & connector (smoke everywhere). Had to disconnect the ABS completely. Any advice on removing & replacing the ABS wiring harness?

Otherwise car runs like a dream. Just renewed the car papers for another 6 months. Then have to decide to keep or scrap it & look for another 126.
 

·
Registered
300 SEL (1989)
Joined
·
369 Posts
Discussion Starter #3
A/C fully charged & works well when clutch engages.
I think it's an electrical or relay problem.
Ambient temperatures high all the time so the clutch should always kick-in.
 

·
Moderator
1991 500SEC sub 50K mi. 1987 560SEC Now 150K mi. 2018
Joined
·
4,292 Posts
Hi jdc1244a,

"AC full charge?" is a good question.

Just got back from Florida today. In HEAVY traffic ala Atlanta yesterday, my 560 nearly overheated (100+ degrees on the gauge). A local independent MB repair shop (with 6-8 W126 cars in the lot) diagnosed the problem as insufficient freon charge in the AC after we saw bubbles in the sight glass. He bridged some wires to the fan with a 10a blade fuse (fan OK/IGN on) & sent me home to Boston. I did ask him if they would add R12 'till the bubbles went away'. They preferred not to apply a bandage....... so I drove home with the Aux fan on & the engine temp never got over maybe 87 degrees.

The AC charge affects several items I'd not thought about. For over a year the climate control has been flawless.... a couple of days ago, my ACC fan was running (3rd+) speed to keep the cabin temp reasonable at 70F during high 80s + temps down south. Last year, I remember it cut down to almost nothing after a bit of driving........

MBL
 

·
Registered
300 SEL (1989)
Joined
·
369 Posts
Discussion Starter #6
Sorry! haven't got the hang of it yet.
 

·
Registered
1991 300 SE
Joined
·
18,534 Posts
Ok, that’s better…

Now you need to cut and paste the banner link to the sig field, looks like part of it’s missing.
 

·
Registered
300 SEL (1989)
Joined
·
369 Posts
Discussion Starter #8
In Singapore A/C is a must all the time.
Airconditioning has been playin up of late. Sometimes its on & other times the clutch doesn't engage. Checked the R12 charge etc. When it's runing it's cold. Drove me nuts for months - family members insisted I get rid of the car. Thought about the dry solder joint on the fuel pump relay I experienced on my 280, so I thought I'll pulled out the A/C relay & take a look. Can't detect the dry joint with the naked eye. Resoldered the 3 joints to the relay.
What a relief, A/C clutch kicked in, . - I hope this fixes the problem, so I now can keep the car.[:)]
 
1 - 8 of 8 Posts
Top