Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1979 300D - 108k miles/ 2014 E250
Joined
·
220 Posts
Discussion Starter #1
I should be getting the ACC II upgrade from Unwired Tools off the UPS truck today! I had another post on here about my servo apparently dying and was trying to decide what to do (get the upgrade or go with a rebuilt one). After talking with others and researching I went with the upgrade. I even called Steve (who started the company) about it.

Anyone installed one recently? Any tips?

Looking forward to doing it - might even do it tonight or in the am.

Thanks
 

·
Registered
1979 300D - 108k miles/ 2014 E250
Joined
·
220 Posts
Discussion Starter #3
So far so good! I took my time and was careful with the directions. They did fail to include one part in the bag, a little t-fitting used to tap into a vac line that apparently always has vacuum. So now everything is hooked up but that. Guess I will have to wait to next week to try it out.

I don't imagine that is something I can pick up at the local O'Reillys...:crybaby2:
 

·
Registered
1979 300D - 108k miles/ 2014 E250
Joined
·
220 Posts
Discussion Starter #4
Actually, maybe I can... just looked and they seem to have something that may work.

Will check the ol' NAPA on MOnday too....:thumbsup:
 

·
Registered
1979 300D - 108k miles/ 2014 E250
Joined
·
220 Posts
Discussion Starter #5
Got it hooked up last night and it WORKS!!! Was happy and quite relieved that the system worked as advertised. They did leave out a t fitting and the instructions were not clear on tapping into the vac system, but I figured it out after a trip to the Advance Auto for some vac connectors. I did call and leave a message for Steve at Unwired Tools a few days ago about the missing connector but he did not call me back.

For $700 you would think I would at least get a return call, but the system works that is the main thing!
 
1 - 5 of 5 Posts
Top