Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
1998 C230 my AC compressor has no power , what this code means 459 ( serial interface) descharge and recharge the freon, pressure is now good replace the evaporator temperature sensor . Please help me.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Freon pressure with the system off is 80. I tried to jumper the compressor and it works, I get the power from the fuse box, that it will turn off at the same time when I turn off the engine, it's just so hot and I need AC very badly but I don't want it like this, don't have enough money for now to see a mechanic to fixed the problem.


Sent from my iPhone using AG Free
 

·
Registered
2010 E350, 2005 Tundra Sold the 1998 C230
Joined
·
322 Posts
Compressor cycling is computer controlled so I think what is most likely happening is that the computer is preventing the compressor from cycling in an attempt to prevent further damage. I ran into what I think is a similar issue with my car that was low on freon. After we recharged it, it would run some from cold but then later would not run at all. Getting into the diagnostics via the ac control panel and clearing out the codes seemed to make the difference for me. I also replaced the evap temp sensor and that may have been the original failure point. When it goes, the system thinks the evaporator is frozen so it shuts down the compressor to prevent damage.

Take a looksee here, this should explain how to get into the diagnostic mode on the car:
http://www.benzworld.org/forums/w210-e-class/1384396-automatic-climate-control-diagnostic-trouble-code.html
 
1 - 6 of 6 Posts
Top