Mercedes-Benz Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey Fellas, I am new to this forum, and I would like to say that I am glad I was able to find you guys, I hope to be a regular here, and I've liked what I have read so far, but I do have a question.

I recently got a 95 S500 for my wife, car came to me as a trade, this is my first Mercedes ever, so I am very pleased with the car and exited at the same time, however, the car has a little problem.

When the ac is on, I can only run it in auto, the center vents on the dash blow cold air, but the vents on the outer side of the dash (left & right) blow hot air, as well as the defrost, if I run the ac in any other mode other that auto, I can not stop the defrost from blowing hot air, for now, the side vents are shut closed and I'm only using the center vents, honestly, since I do not know much about this cars, I wanted to get rid of the car a few weeks ago, but my wife loves it and I do like to drive it too, so I would like to find a cure for it and enjoy it.

I have read about the Duo Valve going bad on this cars, however, I don't know what it looks like or where it's located at, if you guys can elaborate on it one more time, I sure would appreciate it.

Thanks.

Jose
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,776 Posts
Hi
Have you tried the 2 Red & Blue Buttons on your upper Dash ,the blue for cold & red for hot ,they activate something under there and i noticed on my 500 that it has to do with the outer airoutlets , defentitely something there , your main Control may needs to b changed or has a contact somewhere ,old fashion try ,give it a good Wack on the side ,it workt for me ,the duovalve on my 500 is under the location on the Pic,u can't miss it .
Ciao
When u turn the Aircon on make sure u dont press EC or any other button , test ,Press Auto plus turn the wheel all the way to the blue section until u feel the click ,when it's on, tap the button you want it on several times until the red light on that specific button turns on it may fixes itself sometimes .
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for the reply.

Yes, I know about the blue and red buttons, I do have the blue one pressed for ac and the red one for heater, I have located the duo valve just like you illustrate in the picture above, I have give the ac control a good whack a few times but it still doesn't work, I'm going to try and diagnose the ac to see if I have any trouble codes.

Thanks.

Jose
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,776 Posts
So u have ,of course,AC Gas , i assume the Duovalve is stack ,like Bayhas mentioned ,a good Whack with a Hammer ,wow wow, not so fast ,a little Tap should do it , if thats not it try a New Centre Control asembly ( 2nd Hand ) , but than again ,another Member here may have another Solution 4 you to .
Ciao & Good Luck:thumbsup:
 

·
Registered
W140 Mercedes 500 SE, 1992, European, 440.000 km
Joined
·
3,959 Posts
I can not stop the defrost from blowing hot air

defrost is built to blow a hot air and only a hot air. nothing but a hot air.:)
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,776 Posts
defrost is built to blow a hot air and only a hot air. nothing but a hot air.:)
Yes , true ,but it only comes out from the Top for the fast Windscreen Defrosting,it has nothing to do with the other Vents outlets or buttons ,there is only 1 for that anyway .
Ciao
 

Attachments

·
Registered
W140 Mercedes 500 SE, 1992, European, 440.000 km
Joined
·
3,959 Posts
yes of course, defrost works vertically only for a windshield. From inner side to be precise :):):)
 

·
Registered
W140 Mercedes 500 SE, 1992, European, 440.000 km
Joined
·
3,959 Posts
That is true, but it's not supposed to blow hot air when the AC is working.
then in my car soemthing is wrong (but it is not :)). i do not turn AC off (never) but defrost blows hot air anyway. I am 100% sure that you are wrong :) because I do not have any fault code in my AC, so logically it works 100 % correct ... which means that you are wrong :)

be sure that people will confirm my version. AC can be on, and the MB still produces heat in the cabin. that is inherent characteristic of this car, it was meant so when they built it :D

maybe you do not know that AC is designed also for reducing the moisture content of the air. And that goes with defrost function hand by hand.
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,776 Posts
Sounds like you have discover'd yet another hidden Talent within the W140,i have never tried that yet Aircon on & Windscreen Defrost on , i will check this out but you do sound right already 2 me , the Car was build like it .
Ciao
I surrender now :surrender:
 

·
Registered
W140 Mercedes 500 SE, 1992, European, 440.000 km
Joined
·
3,959 Posts
Sounds like you have discover'd yet another hidden Talent within the W140,i have never tried that yet Aircon on & Windscreen Defrost on , i will check this out but you do sound right already 2 me , the Car was build like it .

it is very simple to understand:

- in most cars (if not in all cars) first the outside air is cooled by AC core which produces cold air (because of gas expansion inside the core). But the temperature of the produced cold air is ca. +6 °C .... not - 40°C :) in this stage the moisture of the air is also reduced because cold air cannot contain so much water than hot air.

- if the AC is put OFF then the outside air is not cooled and it passes through heater core which increases its temperature to let's say +40 °C but this is only for example ... the system then heats the cabin with this warm air.

I think you are bothered with the wrong assumption that cooling and hating are not working together but this is very wrong, because they do. explanation is very simple: when AC works on maximal power it produces +6 °C but as you know the cars are designed to increase the outside temperatures from - 30°C (for instance) to inside temperature +30 °C. so the heater core in the car does not know if it receives

a)the direct outside air with temperature let's say -10°C or
b)the air cooled by AC with temperature 6 °C like I stated.

So the path of the air is:

outside air - AC core - heater core - cabin - way out(the effect of AC when turned ON means nothing to heater in terms of heat, the heater can heat the cooled air without any problem ... but anyway, it is ok to have AC on to reduce the moisture)

I hope it is clear now :). trust me, I have built-in once a complete AC device into another car and it worked. I was forced to study how the thing works.


P.S.: there is a big difference between good and bad AC devices: in bad cars the AC cannot function if outside temperature is below +5°C which means that you will have foggy windows, ecpecially if there is raining. In a good car, like MB, AC will work also at lower temperatures and therefore it will reduce the content of water in the cabin air, so the windows will not be foggy.I never turn my AC off. first because of the above facts and second because i believe it is better for an AC system to be constantly in move.
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,776 Posts
Hi
OK. Today I finally remember'd to try this out unfortunately it dosent work When the Air con is on & u press Defrost it turns the Aircon automatically off turn off Defrost & the Aircon comes back on if u do it the other way around its the same effect .
Ciao:surrender:
 

·
Registered
W140 Mercedes 500 SE, 1992, European, 440.000 km
Joined
·
3,959 Posts
Hi
OK. Today I finally remember'd to try this out unfortunately it dosent work When the Air con is on & u press Defrost it turns the Aircon automatically off turn off Defrost & the Aircon comes back on if u do it the other way around its the same effect .
Ciao
I am such an idiot. Of course you are right. It is also in manuals that AC goes off when defrost is on. it is actually my mistake but it happened because of game of words. So I admit that actually my statement about defrost - AC is wrong, however heating and "AC on" go together hand by hand like I wrote above. I think AC turns off (when deforst is on) in our cars only to increase the temperature of hot air blown onto the windshield for several degrees.

So I apologize for my statement that deforst and AC works together. It would be correct to write: they could work together or there is no problem to work together.
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,776 Posts
Hi
No Damage done but you got me thinking for a minute there that something was broken on my Car , if something should brake i fix it instantly otherwise i cant rest .
Ciao :thumbsup:
 

·
Registered
W140 Mercedes 500 SE, 1992, European, 440.000 km
Joined
·
3,959 Posts
Sorry sorry sorry :bowdown::bowdown::bowdown:

That is true, but it's not supposed to blow hot air when the AC is working.
actually the above statement was a reason for my reaction. The above statement is not correct in strict meaning of the word because defrost works when AC is on, it only overrides it (turns it off). In another words, defrost works always when we press the corresponding button, so specifying when defrost is not working, is not in place.
 

·
Registered
W140 Mercedes 500 SE, 1992, European, 440.000 km
Joined
·
3,959 Posts
Grrrrrrrr:eek:

Actually nothing of the above statements are 100% correct.


1) EC on (red light on) means that AC is turned off (heating and blower work, cooling and decreasing of moisture do not work). If so, then pressing the defrost button turns it on (EC red light goes off). If you disengage defrost then EC red light will again come on which means that AC is OFF (but only if the EC red light was on before defrosting).

2) this is logicall because when using defrost we also want to get rid of eventual moisture (fog) inside the car, and only AC on can do it.

I knew that defrosting also controls AC, therefore I believed you that defrosting works with AC off. But the truth is that it actually works with AC on. At least it is so in my car. So I was actually the closest to the truth, your remarks only confused me.:crybaby2::crybaby2:
 

·
Registered
1992 400 SE
Joined
·
73 Posts
personally, i think u will be very very sorry u bought that car mate, sure they look fantastic, no argument there, the bodywork is pretty good also , but the bits that makes these cars, ie all the electronic gizmos, and gadgetry , are purely an absolute disasterous nightmare, as the reliability is atrocious. i am going to collate a list for the forum of all the pieces that have failed to date on my car, i will be purchasing a new quality vehicle in the near future, hyundai getz, and i have absolutely no doubt that when its the same age as my 400 is no where near as many bits will have needed to be replaced . !
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,776 Posts
personally, i think u will be very very sorry u bought that car mate, sure they look fantastic, no argument there, the bodywork is pretty good also , but the bits that makes these cars, ie all the electronic gizmos, and gadgetry , are purely an absolute disasterous nightmare, as the reliability is atrocious. i am going to collate a list for the forum of all the pieces that have failed to date on my car, i will be purchasing a new quality vehicle in the near future, hyundai getz, and i have absolutely no doubt that when its the same age as my 400 is no where near as many bits will have needed to be replaced . !
Hi
Please dont take no offence Dave but the Car you bought must have been a one of Lemon or maybe misstreated by the previous owner (neglected due to the cost of Parts ) My Car is a Perfect example of the w140Quality,absolutely & always 100% ,everythink works & i'am sure that there are many many still out there just like it ,these days People r only out to look for bargains ,cheap cheap cheap and then they complain later ,who cops it ,in our case the poor W140 ,these cars are not for everyone ,a lot of people want them and when they have it and something does brake down they replace it with cheap aftermarket Parts because they cant pay for the real thing,would u pay for example ,Wiper relay $195 2nd hand or $450 new ,i choose the $450 1 so i dont pay twice 4 it & i know it will work for years to come. I do have 3 other cars made in Japan and yes they are ok for in the city but are nowhere near the Quality of this Car ,my Car is a 93 Model & it looks as if it came out of the Factory yesterday when it's all cleaned up ,i dont think that a Hyunday will look that good after 5 Years with 180,000 Km on it ,that is ,if it will make the 100,000Km mark 1st, our cars S500/600 r just running in at that if they have been Serviced etc...,i recently had a 2500Km trip with my S500 & it dident want to stop not even for Petrol ,it loved the Highway so much that when i was finally back i too wanted to go again , the Car dident feel all those Km at all , as if i wend around the block .
How long have you had the w140 for anyway to give you this bad impression on it ?
Ciao:thumbsup:
 
1 - 20 of 21 Posts
Top