Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
1997 E320
Joined
·
3 Posts
Discussion Starter #1
Ac works for about 5 minutes compressor shuts off. Put gauge on high pressure side on it goes to the retard side, building up to much pressure where should I start to look for the problem. 1997 E320
 

·
Premium Member
1998 E320 base sedan @ 160kmiles
Joined
·
7,215 Posts
Have you recently charged the system ? what are the low and high side readings when the compressor is running and not running ?
 

·
Registered
Dallas, Texas
Joined
·
8,209 Posts
How high? Overcharged? Full of air? Fan clutch pulling air? Condenser fans running?
 
  • Like
Reactions: mrboca

·
Registered
1997 E320
Joined
·
3 Posts
Discussion Starter #4
Can’t remember the pressures but on high side gauge went to retard on high end condenser fans not running I’ll get pressure readings when I gauges back no current coming to fans. Fans do works i jumped them with leads
 

·
Registered
E250 Bluetec Sprinter250 Bluetec
Joined
·
37,026 Posts
How about spending about 90 seconds of your time and doing proper troubleshooting per link in stickies?
 

·
Premium Member
1998 E320 base sedan @ 160kmiles
Joined
·
7,215 Posts
If you obtain and post high / low readings when the compressor is running and not running, it will be very helpful. The front fan will start turning when the high side pressure is above about 200 psi. When the compressor stops turning the fan will stop (unless the engine coolant temp is also quite high).
 
1 - 7 of 7 Posts
Top