Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
02' ML270 CDI
Joined
·
41 Posts
Discussion Starter #1
Hey guys,
Yesterday I had a problem with the ac zone settings. When I even select the blowing zone to the footwell air didnt stop coming from the windshield. Any zone I set I've couldnt stop air blowing from windshield. So the windshield always gets foggy from the outside and its really annoying.. I changed the settings to stop it blowing like 50 times today. Now it dosent blow air from the windshield at all. but now I will have problems with defrosting the windshield in winter time. And sometimes even if I set the ac zone to center vents it dosent blow from the center I can feel the air is just traveling inside the dash. So what should I check for ?

sorry for my bad english:rolleyes:
greetings
 

·
Premium Member
02 ML320 06 ML500
Joined
·
17,104 Posts
You will probably have to replace the Defroster Actuator which is located behind the ETC (Trans, Control) Module.

Remove the cover below the instrument panel and then look for the black box as shown in the photo. Remove it and its bracket and what to see that it moves when selecting different settings.
 

Attachments

·
Registered
02' ML270 CDI
Joined
·
41 Posts
Discussion Starter #3
You will probably have to replace the Defroster Actuator which is located behind the ETC (Trans, Control) Module.

Remove the cover below the instrument panel and then look for the black box as shown in the photo. Remove it and its bracket and what to see that it moves when selecting different settings.
thanks man.
Last night it started working again but even if I set the zone to footwell, windshield vent never stops. I am fed up with wiping the windows every 10 seconds because of the fog on the windshield. should I change that part ? or putting some oil to the moving part can be useful ?
 

·
Premium Member
02 ML320 06 ML500
Joined
·
17,104 Posts
thanks man.
Last night it started working again but even if I set the zone to footwell, windshield vent never stops. I am fed up with wiping the windows every 10 seconds because of the fog on the windshield. should I change that part ? or putting some oil to the moving part can be useful ?
As I said in my earlier post, you must first check to see that the levers are moving. I would say you need to replace it, but check first.
 
1 - 4 of 4 Posts
Top