Mercedes-Benz Forum banner

1 - 20 of 303 Posts

·
Registered
R230 SL350 Presnt, Past - W208 CLK230K 2000, W203 C Class, W202 C Class, W210 E Class, W201 190E
Joined
·
1,465 Posts
Discussion Starter #1
FIXED!
Well i think I have finally solved the problem with my ABS/ETS lights.
It seemed to be down to buying a replacement aftermarket brakeswitch
the whole time!!

I went to replaced the usual suspect brakeswitch about 6 weeks ago but
Mercedes at the time was closed for stock counting. So I went to
Eurocarparts to but the switch instead. The price was only about £3
cheaper (£9 instead of MB £12) so I thought there cant be much in it.
I fitted the Eurocarpart switch and without pressing the brake the
ABS/ETS light came on after 2 mins! I then noticed that when I pressed
the bake the brake lights only dimmed and did not go out? as if there
was a short. I checked the ratchet length of the brake switch plunger
and it was operating fine.
So back to Eurocarparts to get another switch and this time the bake
ligths went out when fitted, but 10mins later the ABS?ETS lights onthe
dash came on again!

I had noticed however that the ABS/ETS lights seemed to come on mainly
when I pressed the brake or shortly after, so one last try I went to
Mercedes and bought an original bake switch, and Voila so far no more
warning lights, for 3 days!!!

Moral is by Orignal parts when electrics are involved as Mercedes are very delicately balanced.

....and of course cruise, abs and traction are all back again too,
just in time for the snow!!
 

·
Registered
2008 S550
Joined
·
24 Posts
Congratulations! My E-Class has the same problem. Would you mind posting the DIY procedure for replacing the brake switch? Thanks.
 

·
Registered
R230 SL350 Presnt, Past - W208 CLK230K 2000, W203 C Class, W202 C Class, W210 E Class, W201 190E
Joined
·
1,465 Posts
Discussion Starter #3 (Edited)
RE: ABS/ETS finally FIXED! DIY procedure to replace Brake switch

How to replace the Brake Switch:) REVISED as I have noticed there are nearly 2000 views on my original posting I thought I would improve it with some more photos.!)
mrwilliamsburg....
Please note that my car is a UK right hand drive model!

First you need to remove the underside panel of the drivers panel:)See 4 photos with red arrows )
There should be 4 Phillips screws you need to undo first.

1 near the bonnet release.
2 near the front the opposite side to bonnet release.
3 underneath in middle
4 at the back above pedals.

With these screws removed you need to pull the tray towards you as there are clips on the front under steering wheel. Then near the centre console you need to pull downwards as there are 3 clips there also. That should be it! (Please note that I have added a photo showing the under try being pulled out which is on a left hand drive model, the steering wheel is also removed but obviously you dont need to do this!)

To remove the Brake Switch:
I found it best to put the seat right back and lie almost on your back on the floor. The switch is located above the brake pedal at the back. On the top of the brake switch in the 12 o'clock position, there is a little plastic catch, which you need to depress and then at the same time turn the switch clockwise a quarter of a turn. You may find it easier to unplug the two wires first. Once turned, you can remove the switch.
Pay attention to the length of the actuator (plunger),as it is on a ratchet system and your new switch needs to be the same length, otherwise it will not operatet properly.
Use an original Merc brake switch and just rotate the sitch anti-clockwise this time to fit back in the mounting.
Good luck, and I hope it fixes your car.!;)
 

Attachments

·
Registered
Joined
·
9 Posts
Thank you very much for these instructions. I have the same problem on my 97 E420. I will use your instructions and try and fix this problem.
 

·
Registered
2005 E500 4matic, 1998 E430 Sport, 1995 E320 Wagon
Joined
·
66 Posts
Not Fixed

I have a 96 E300 Diesel and thought I might have had a lucky shot following your success but no. My abs/ets light will come on while driving or even come on when first starting the car - a couple times it would appear to come on after I pressed the brake pedal so I went to the dealer and bought the MB part and installed it per the manual. It seemed to help at first as went a week without any problems but that was just a coincidence. The abs/ets lights will come on, sometimes like today when they come on after a moment the speedometer also went to zero. This problem is absolutely the most aggrivating thing; what in Gods name would cause the speedometer to fail and be connected to the abs/ets systems - is it a wheel speed sensor? Anyone have this issue?

Alan
 

·
Registered
1999 E430 Sport
Joined
·
7 Posts
Abs/ets Fixed!

I had the same problem, and thanks to your post it is now fixed. I didn't install the new switch (my shop did it), but after the new switch was installed the brake lights would flicker going down the street when not braking. I referred to your post, pulled the switch and adjusted the ratchet by pushing the switch in (all the way at first by mistake) then backing it out to the right length. That solved the problem. You can hear the ratchet click as you adjust. Just thought I'd post in case anyone else has flickering brake lights. THANKS for your post!!! It solved the ABS/ETS problem!
 

·
Registered
1999 E430 Sport
Joined
·
7 Posts
One other quick note - on my 99 E430 Sport the plastic catch (that allows you to turn the brake switch 1/4 turn to remove) is located at 9 o'clock instead of 12 o'clock. No big deal.... different year, different location.
 

·
Registered
Joined
·
1 Posts
I found this information helpful in fixing 98 E300 and thought I would share what I found with the old switch I took out. The contacts on the one side of the switch are badly pitted, there must be a bit of current going through that part of the switch. I attached a picture of the inside of the switch to show the part falure. I hope this helps the other people like me that want to understand what actually failed.
 

Attachments

·
Registered
Joined
·
1 Posts
Thanks very much for the post. I got the same problem and I removed the swith, lengthened the ratchet and put the old switch back in. It solved the problem.
 

·
Registered
2002 S600
Joined
·
10 Posts
SOS - Stuck in Park, Cranks when it wants to, ESP/BAS/Airmatic ERRORS...

I've got a a similar issue but with much more kinks...

Friday night the valet brought my 2002 s500 around to the front of the restaurant with no problems. They turned it off and when I was ready to leave, I hopped in, turned it over, nothing. The dash board lights up like a christmas tree giving me a Check Engine light, & ESP, BAS, Airmatic ERROR messages. I turned the automatic headlights off and tried it again, it started. I got it home, started it up the next day, no problem, ABS light on. Went to the grocery store, came out, wont start. And when I say "wont start" I mean won't crank or anything. Its like having your key in the II possition. I tried it a few times and nothing. So I left it there and walk 2 blocks home. I returned later to see if it just need some time to stop hating me and, it started! But wont come out of park.

I replaced the battery, it started, I turned the wheels lock to lock to erase the codes, & then I turned it off. I tried to start it again and nothing. No crank.

It cranks when it wants to and when it does, its stuck in park. Oh and one more thing...the A/C won't work. I noticed that the A/C display was fading on and off that first night on the way home from the restaurant. When the car decides to crank & turn over, the only thing that will get the A/C to do anything is if I hit the REST button. Isn't this only supposed to work when the cars off to push residual hot air off the engine during over heating? -My temp gauge reads normal btw.

SO....with ALL that being said....PLEASE HELP!! My car has been in the Ralph's parking lot for almost a week & no one, not even the dealer can tell me what to do!

Oh, no one will tow it for me because it wont come out of park...????

H.E.L.P.

THANK YOU!
 

·
Registered
Joined
·
41 Posts
Replacing the brake switch also solved my ABS/ETS malfunction. It's pretty easy to do it yourself, but prepared to lay face up on your footwell. Thanks!!!!! The switch cost me about $23 at the MB dealer in Santa Monica....
 

·
Registered
'84 SEC EuroCoupe, '85 200T EuroWagon, 2012 Nissan Maxima SV Sport
Joined
·
3,172 Posts
ForrestBlackburn said:
I've got a a similar issue but with much more kinks...

Friday night the valet brought my 2002 s500 around to the front of the restaurant with no problems. They turned it off and when I was ready to leave, I hopped in, turned it over, nothing. The dash board lights up like a christmas tree giving me a Check Engine light, & ESP, BAS, Airmatic ERROR messages. I turned the automatic headlights off and tried it again, it started. I got it home, started it up the next day, no problem, ABS light on. Went to the grocery store, came out, wont start. And when I say "wont start" I mean won't crank or anything. Its like having your key in the II possition. I tried it a few times and nothing. So I left it there and walk 2 blocks home. I returned later to see if it just need some time to stop hating me and, it started! But wont come out of park.

I replaced the battery, it started, I turned the wheels lock to lock to erase the codes, & then I turned it off. I tried to start it again and nothing. No crank.

It cranks when it wants to and when it does, its stuck in park. Oh and one more thing...the A/C won't work. I noticed that the A/C display was fading on and off that first night on the way home from the restaurant. When the car decides to crank & turn over, the only thing that will get the A/C to do anything is if I hit the REST button. Isn't this only supposed to work when the cars off to push residual hot air off the engine during over heating? -My temp gauge reads normal btw.

SO....with ALL that being said....PLEASE HELP!! My car has been in the Ralph's parking lot for almost a week & no one, not even the dealer can tell me what to do!

Oh, no one will tow it for me because it wont come out of park...????

H.E.L.P.

THANK YOU!
I'd go back and ask the valet parking guy what the hell he did to your car while you were inside eating.:mad:
 

·
Registered
2008 BMW 528i,1999 Lexus 400LS, 2014 e250 BlueTec
Joined
·
635 Posts
I'll go for CPS sensor first and on to ESP/BAS which could well be brake switch. Try to have the codes read out with OBDII.
 

·
Registered
2007 E350 4MATIC
Joined
·
45 Posts
blkE430sport said:
One other quick note - on my 99 E430 Sport the plastic catch (that allows you to turn the brake switch 1/4 turn to remove) is located at 9 o'clock instead of 12 o'clock. No big deal.... different year, different location.
I had the same problem that you were having about the ABS/ETS. I went to the dealer and purchased a new Brake Switch. Once installed the ABS/ETS still comes on. Any suggestions?? Response will be fully appreciated.
 

·
Registered
1996 E320
Joined
·
6 Posts
We had the ets/abs light syndrome also. New brake light switch installed and all is well. Cheap fix ($15 US)and tons of instructions on this forum. Also the clock was going looney in the instrument cluster. It would change time randomly. That too seems to have stopped after the brake light switch replacement. STRANGE.
 

·
Registered
1996 210.020
Joined
·
3,972 Posts
A1EK said:
Pay attention to the length of the actuator (plunger),as it is on a ratchet system and your new switch needs to be the same length, otherwise it will not operatet properly.
I've not changed this part, but it was my understanding that you pull the plunger all the way out and let it self-adjust.
 

·
Registered
2000 S430 (W220)
Joined
·
58 Posts
Thanks a MILLION! I own a 98' C230 and recently had the ASR & BAS senson light turn on and thought here we go, time to begin spending money on expensive Mercedes-Benz repaires. Luckily I spent a few hours researching for myself online about the potential cause of the problem and that is when I stumbled across your post, abseloutely PERFECT! You provided perfectly easy instructions and it worked like a charm. The end result is no more warning lights on my instrument panel and I am only out about 20 bucks, the cost of the brake switch. Thanks again for the wonderful post!
 
1 - 20 of 303 Posts
Top