Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,332 Posts
Discussion Starter #1
Upon starting the car I get 3 diagnostic messages. ABS/Brake Assist/Stability Control.....Take to Workshop.

Also, there is a rapid tick tick tick sound coming from a module in the engine bay on the drivers side of the car. Sounds just like a spark plug arc but it's truely coming from that module. The module in question is the one that looks like a machined block of aluminium with 6 hydraulic lines attached near the washer fluid washer reservior, not the master cylinder/brake fluid reservior by the firewall.

I'm not going to attempt any DIY but any ideas on what the problem is? Should I take it to the dealer or can a good indie handle this kind of problem?
 

·
Registered
Joined
·
1,332 Posts
Discussion Starter #3
Sorry, I don't have a code reader. Should I take it to an AutoZone and get the codes read before I take it to the dealer?
 

·
Premium Member
Joined
·
17,193 Posts
Yes, that is what I would advise. AutoZone will read them for free but do not trust their interpretation(s). Post them here, or look in the Stickys and the codes/interpretations are there. Good Luck.
 

·
Registered
Joined
·
3,926 Posts
Upon starting the car I get 3 diagnostic messages. ABS/Brake Assist/Stability Control.....Take to Workshop.

Also, there is a rapid tick tick tick sound coming from a module in the engine bay on the drivers side of the car. Sounds just like a spark plug arc but it's truely coming from that module. The module in question is the one that looks like a machined block of aluminium with 6 hydraulic lines attached near the washer fluid washer reservior, not the master cylinder/brake fluid reservior by the firewall.

I'm not going to attempt any DIY but any ideas on what the problem is? Should I take it to the dealer or can a good indie handle this kind of problem?
That sounds like the ABS pump/module.

It also sounds like a brake switch failure.

Take a look here:

http://www.benzworld.org/forums/w210-e-class/1236763-abs-ets-finally-fixed.html
 

·
Registered
Joined
·
1,332 Posts
Discussion Starter #6
Thanks Lou,

I think it might be the brake light switch based on that link. I wasn't going to try to dyi anything with the brakes, but replacing the switch sounds fairly fool proof so I'm going to give it a try.
 

·
Registered
Joined
·
8 Posts
hey figuero, did replacing the switch work for you? I am having these same exact symptoms and want to save a trip to the dealership if possible
 

·
Registered
Joined
·
1 Posts
Figuero, I am looking at a 2000 E430. It has the clicking from the ABS module. I noticed that it cycled on and off. did you notice that yours cycled the clicking on and off while sitting there and idling? tia
 
1 - 9 of 9 Posts
Top