Mercedes-Benz Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have a CLK 430 and my ABS/ BAS ESP light keeps coming on. I have read many forums regarding this topic and have just about everything I can imagine on my car. The light comes on only when I'm driving for about 15- 20mins into the highway and doesn't turn off until I turn my car off again. Once I turn my car back on the light goes away. I have replaced all my ABS Sensors, brake light switch, ABS Hydraulic Pump, Valve Body, input and out speed sensors above the valve body......and nothing. I don't know what else to do. Can anyone help me? I feel like blowing the car up. Its frustrating! :mad:
 

·
Registered
Joined
·
474 Posts
I have a CLK 430 and my ABS/ BAS ESP light keeps coming on. I have read many forums regarding this topic and have just about everything I can imagine on my car. The light comes on only when I'm driving for about 15- 20mins into the highway and doesn't turn off until I turn my car off again. Once I turn my car back on the light goes away. I have replaced all my ABS Sensors, brake light switch, ABS Hydraulic Pump, Valve Body, input and out speed sensors above the valve body......and nothing. I don't know what else to do. Can anyone help me? I feel like blowing the car up. Its frustrating! :mad:
I had the same prob b4 and it came on like 3 minutes within driving and wont go away till i turned the car off.. All what i did, i changed my pads and prob was gone.
B4 that, took my car to my mechanic and ran the diagnostic on it and everything was fine and last resort, he asked me to change the pads and honestly it went away since that time.
Otherwise, i would not know ...
 

·
Registered
Joined
·
15 Posts
does the car cut out or sputter? mine is doing it when i floor it, the light comes on and the car sputters. i limp over to the side of the road, shut it off and turn it on and away i go
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
No my car doesn't cut out and yes when I do pull over and turn off the car then turn it back on the lights go away. Thats doesn't correct the problem because later on they turn back on again.
 

·
Registered
Joined
·
144 Posts
it could be a simple sensor replacement that costs $15 from autohaus.com

check out a couple prior threads on this topic. I have the same problem as well, and it keeps coming on and off....

Do this first, before spending major bucks
 

·
Registered
Joined
·
134 Posts
May want to check it for codes again with an SDS (when the light comes on), don't cycle the key, and also check actual values of all the brake system including the brake booster diaphragm membrane travel sensor which monitors motion of the vacuum diaphragm inside the booster.

Also remember those stop lamp switches are cheap and no better than the old one you took off, so you may have a bad (new) one.

Do you have any after market equipment installed like a TV system or anything that may need to see a brake light signal?

Oversized wheels?

You may need to reset parameters.
 

·
Registered
Joined
·
565 Posts
When you first turn your car on & the warning lights are off, do they come on as soon as you step on the brake? If yes, itks clearly your brake switch & an easy fix ($15-$20). Your brake lights will probably not function properly either if your brake switch is defective.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
May want to check it for codes again with an SDS (when the light comes on), don't cycle the key, and also check actual values of all the brake system including the brake booster diaphragm membrane travel sensor which monitors motion of the vacuum diaphragm inside the booster.

Also remember those stop lamp switches are cheap and no better than the old one you took off, so you may have a bad (new) one.

Do you have any after market equipment installed like a TV system or anything that may need to see a brake light signal?

Oversized wheels?

You may need to reset parameters.
I do have oversized wheels (20in wheels). How do I reset parameters? You also mentioned checking values of all brake system including the brake booster diaphragm membrane travel sensor which monitors motion of the vacuum diaphragm inside the booster. How do you check that and what value is it suppose to be? I have spent over $1500 in trying to fix this problem and I have failed every single time. Please do help me
 

·
Registered
Joined
·
350 Posts
Find a tire size calculator on the internet. Bump them up against stock tire sizes to see how dramatic the diameter changed. Not sure of the exact figure, but if its dramatic it'll cause problems like that. (ie. car being a
'99: stock front is 225/ 45R-17; comparable size would be 225/ 30R-20.)
Play around with the calculator. If your way off then...

Also, I would follow the recomendation of ordering a new stoplamp switch.
Very possible 'Bad From Stock'.

How are the brake pads?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10 (Edited)
Find a tire size calculator on the internet. Bump them up against stock tire sizes to see how dramatic the diameter changed. Not sure of the exact figure, but if its dramatic it'll cause problems like that. (ie. car being a
'99: stock front is 225/ 45R-17; comparable size would be 225/ 30R-20.)
Play around with the calculator. If your way off then...

Also, I would follow the recomendation of ordering a new stoplamp switch.
Very possible 'Bad From Stock'.

How are the brake pads?
The brake pads are ok. I checked the tire size calculator and its 1.37% too slow. How do I bring it up to par? How do I program it to the new size?
 

·
Registered
Joined
·
32 Posts
replaced the lamp switch but problem still there.... the main thing I am concerned with is that there are no brake lights........ should I buy another lamp switch to try ? There are no refunds or exchange with these parts....
 

·
Registered
Joined
·
711 Posts
replaced the lamp switch but problem still there.... the main thing I am concerned with is that there are no brake lights........ should I buy another lamp switch to try ? There are no refunds or exchange with these parts....
:confused:replaced bl switch AND bl's are still out? hmm now I'm stumped. not sure of the clk but if the switch is anything like my ml's, you have to install correctly so the plunger will detonate and process signal correctly. esp. if the bl's worked before you changed the part.
 

·
Registered
Joined
·
711 Posts
does the car cut out or sputter? mine is doing it when i floor it, the light comes on and the car sputters. i limp over to the side of the road, shut it off and turn it on and away i go
cali, search limp home mode on this forum & in your manual. if you get a cel light, check to see what the code is. if abs is activating w/out your inputs + your tranny is in limp you probably have larger issues & they can be dangerous to say the least:eek:
 

·
Registered
Joined
·
144 Posts
my brake light went completely OUT too.. .. i already replaced the brake light switch, and got nowhere.. now what??
 

·
Registered
Joined
·
627 Posts
brake pad SENSORS

I was having the same issue, the pads looked ok but each pad has an electrical sensor. They get issues from corrosion or when they get wet or have contunity issues.

They are cheap & easy to replace. To test this turn on car with the wheel removed you said its ok when first start, then remove the pad sensor cable, observe the lights on dash to see if this happens
 

·
Registered
Joined
·
8 Posts
I looked this issue up in my owners manual and one cause for the light coming on is that the battery voltage is too low. If the voltage goes below 10 then the light willcome on until the voltage raises back above the 10 volt level. I hope this may help.
 

·
Registered
Joined
·
226 Posts
Same thing happened to my car..1st the radio sometime off for 1 second and comes back on...then most of the lights in the panels blink for a second and then stop...and sometime the engine die at the red light. I have to put it in neutral at the red light to prevent this. Most recently, the ESP,ABS lights would come on and I had to reset them for them to turn off. HELP PLEASE.
 

·
Registered
Joined
·
3 Posts
This is a quick simple fix to start. I tried it and it work. Turn the car off then restart it. Then turn the steering wheel as far as it will go to the right then to the left. Do this a couple of times. All three systems work together and this is a quick fix. Surprisingly all 3 lights went out and haven't come back on.
 
1 - 20 of 23 Posts
Top