Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi everyone,

Just got a new one on my beloved SLK 200 R171, 2006 model, 58000 km...

After starting the car, got ABS malfuction (+ ABS amber light on the dashboard), followed by BAS and ESP malfunctions. I noticed that the power steering was u/s.
I stopped the car and restart it, no malfunctions and power steering ok. After driving a few hundred meter, all came again.
I went to MB agent. They found ABS, BAS and ESP fault. They kindly reset/clear everything for a try at no cost and told me to come back if it happens again.
I left the garage, all normal, and a few meters away, all came back with loss of power steering. I left the car with MB agent, waiting for further diagnostic...
Does anyone encountered the same problem or having an idea of what it could be ?
Many thanks !
 

·
Registered
07' slk 55
Joined
·
11 Posts
sounds like intermittantly faulty steering angle sensor. the p/s goes out because there is an assist valve that defaults too closed since it doesnt know how sharp your trying to turn at low speeds.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thank you for the info ! The car is still with the agent, they received the new ECU (Electronic Control Unit)from Germany today and the car should be ready by tomorrow. They told me that if the ECU replacement does not solve the problem, they will investigate further and not charge me for it... I cross my fingers and will keep you updated !
Bernard
 
1 - 3 of 3 Posts
Top