Mercedes-Benz Forum banner

21 - 40 of 70 Posts

W220 Moderator
Joined
7,952 Posts
They are regular .jpg images it's not a forum issue ;)
 

Registered
CL600 year 2001
Joined
95 Posts
Discussion Starter · #23 ·
@Dave you got good pressure figures. Thanks - now I understand, what it has to be when ok! Never seen those high in my Cl 600.

Also the control unit info can be important. I need to check and verify ify with my existing coltrol unit that soonest.

Today's plan was good, but target changed: did not touch MB at all, yet.
 

W220 Moderator
Joined
7,952 Posts
I sorted that CL about 2 years ago, not all at the same time, but in planned stages, I rebuilt both valve blocks, all new rear pipes and all new accumulators plus full fluid and filter change and one strut, it has never given any ABC issues since ;)
 
  • Like
Reactions: Chili58

Registered
CL600 year 2001
Joined
95 Posts
Discussion Starter · #25 ·
I got now my printed my ABC Control Unit version: Do you see there any strange? The car is model 2001.

Its other info is:

FINWDB2153781A019290
ModelCL 600
Engine137970 40 012401
Transmission722628 02 973737
Order Number0 1 839 40236
2681815
 

W220 Moderator
Joined
7,952 Posts
All I can tell from that is that it's an older unit ;)
 

Registered
CL600 year 2001
Joined
95 Posts
Discussion Starter · #27 ·
I managed to install a pressure gauge also today at pressure relief valve.

However noticed that it had a leak; I need to tighten that tomorrow. The leak can be seen on the video; I do not know, if that really matters to today's measurement and conclusions. Maybe it does. - therefore tomorrow the exercise will continue.

The conclusion from today was, that Xentry/DAS/STAR shows the same figures as this pressure gauge. But a bit open is to me, if that small leak would stop raising the pressure. However, at the beginning the STAR was measuring 173 bar, as it does normally - and at the end, when oil was warmer, it showed 163. It never went up higher that 173, which is does and there it cuts raising normally as if it is hitting a limiter on that level.

Tomorrow, I will give a bit hit to suction valve with STAR to see, if it gets higher pressure.


Any strange behaviour on the viedoe?

2681816
 

Registered
CL600 year 2001
Joined
95 Posts
Discussion Starter · #29 · (Edited)
Dave - your screenshot up there looks to solve this finally! I can already thank you I assume.

I checked from my Mercedes sparepart tool EPC now first time what sparepart number my ABC control unit should be.
And the issue looks to be there!

The control unit number that I have there compared to one that it should have according to my EPC:

My number is: 022 545 08 32 - (That is suitable for SL 500 2009 - 2002!!!)
EPC says the correct one for my VIN is: 032 545 54 32

I asked from BALD (MB spares in Germany) this week a quotation for the pump and ABC control unit - just got it last night and read now that: There it is confirmed: The number of the ABC control unit that they offer to me is also that 032 545 54 32 as new one and 032 545 54 32 80 as refurbished

Well, well....where is my Saturday night Bushmills?

Thanks for the support and ideas; we are moving ahead!


2681832
 

W220 Moderator
Joined
7,952 Posts
So now to find a good used one with that part number, I do know for a fact that a lotta bits from an SL ABC are different ;)

CL is same as a W220 ;)

SL probably runs a lower pressure, different regulator, pump or perhaps flow characteristics, hence the issue
 

Registered
CL600 year 2001
Joined
95 Posts
Discussion Starter · #31 ·
I just found out the this A02.... Has been actually in use also in CL600. I was happy too early.

But i already found several with the new A03.... number. And my friend now also offered to give his A02... for test.
 

W220 Moderator
Joined
7,952 Posts
Having a known good part to test with is always a bonus ;)
 
  • Like
Reactions: Chili58

Registered
CL600 year 2001
Joined
95 Posts
Discussion Starter · #33 ·
Having a known good part to test with is always a bonus ;)
I ordered half an hour ago from ABS Specialists in Netherlands a ABC control unit; let's see if that helps. ;) Will arrive maybe on Friday.

After that I have new pump, restriction valve, press relief system and the pipe from the pump to press relief block and the control unit. If that does not help - let's see what would help....any new ideas; plan B?
 

W220 Moderator
Joined
7,952 Posts
After that I have new pump, restriction valve, press relief system and the pipe from the pump to press relief block
I thought you had already changed all that ? Perhaps I am thinking of a different member / thread ?

Pressure relief block then pump would be my first ports of call ;)
 
  • Like
Reactions: Astro14

Registered
CL600 year 2001
Joined
95 Posts
Discussion Starter · #36 ·
I mean that I have changed all those already; some of them at least twice, but not the control unit, yet. Control unit went just to a car instrument workshop, where they checked it and soldered all again. - and I installed it back.

Pressure relied valve is certainly OK. It has been changed twice and its block also once.
 

Registered
2005 S600
Joined
782 Posts
You changed the pressure relief valve twice before?

Then, how did you end up with a part from a different chassis in there?

Where are you getting your parts!!??
 

Registered
CL600 year 2001
Joined
95 Posts
Discussion Starter · #38 ·
You changed the pressure relief valve twice before?

Then, how did you end up with a part from a different chassis in there?

Where are you getting your parts!!??

The reason to change it was not that it was from a wrong chassis. The reason for changing it was, because when the DAS/Xentry measures the pressure it says that the pressure measured is wrong. And it also says that the reason is the pressure relief valve is broken, and does not work properly - and you need to change the pressure relief valve..

The conclusion was that the pressure relief valve may not work properly and let's change it. I had already changed it to a new one from ABC Specialists in Netherlands while doing overhaul. They were in such a goodwill mode that they delivered a new one free of charge. But nothing changed - the issue remains
 

Registered
CL600 year 2001
Joined
95 Posts
Discussion Starter · #39 ·
A bit progress today evening: I received refurbished ABC Control Unit from ABC Specialists Nl and changed and adapted it.

I got immediately first time more than 173 bar pressure - I got 193, which I have measured from other MB earlier, as well!

I had just removed the auxiliary pressure gauge from pressure relief valve, so there is a bit air in system. That obvioysly caused the pressure to drop temporarily, but it anyway immediately jumped back to 193 bar.

Tomorrow I'll do bleeding and we'll see!!

Looks to be very likely that the issue is close to be solved!
 

Registered
2005 S600
Joined
782 Posts
Wow! Never thought that would solve it...my fingers are crossed that this has fixed the issue!
 
21 - 40 of 70 Posts
Top