Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1973 450SL
Joined
·
21 Posts
Discussion Starter #1
My mechanic had just delivered my 1973 450 SL to me after having had a tune up and a new soft top replaced. We were almost out of gas so we went to put some in. He ask what kind I used and I said regular. He said I should be using super unleaded so after putting some in we started to drive away when the car started to chugged about and act like the fuel pump had a problem. He took it back to the shop and had worked on it all day to try and figure out what happened. I never had a problem before with the car using regular and I have in the past put in the higher grade. He himself is a little stunned as the car was running great up until that moment. Any thoughts on this????
 

·
Registered
Depends on the day!
Joined
·
13,337 Posts
Tank of bad gas, be it water or just junk. Try a few cans of dry gas.. If no improvement then I would start by changing the fuel filter.

Did the pump make any odd noises before the car stoped working?

Jonathan
Btw, you really should be using premium in your car, it's cheap insurance.
 

·
Registered
1973 450SL
Joined
·
21 Posts
Discussion Starter #3
Thank you for your reply. I'll start using the better gas once I get the car back. I don't know what kind of noise the fuel pump would make, it just acted like it was not getting any gas so it jerked along and moved very slowly (putt, putt, putt) when I got dropped off back at my house. He told me it had to be towed back to the shop a few miles after he left me. It started up fine then next morning but he wanted to find out why it did what it did before he gave it back to me as he didn't think it was the gas. When I get it back I'll post his results.
 
1 - 3 of 3 Posts
Top