Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
I have read the ultimate soft top controller thread.

I have a couple questions probably for bobterry.

In red is what I have posted on mercedesforum.com
But thought I repost here.

I have a 99 129 SL500 with some issues. I had hard codes of 130, 134, 135, all soft top modules related. I sent the unit to BBA reman it came back with the same hard codes. Got it back today (5-14-08).

All installation procedures from the best of my knowledge was performed 100%. Fresh battery. Synced windows, etcc.. Still having several other codes that clear, 124, 96, 97 133 114, 050. I think those are all codes that are generated from the issues with the hard codes.

The roll bar (Amber) light is always on as is the two red arrows on the roll bar bar switch in the center console.

This is after sending it to BBA. I thought it may be a syncronization issues. But we have tried (most) everything. We can unplug the module for a few minutes plug it back in and it will work for a little while.

Operationally it seems that when you let the top back through the whole cycle that the motor will keep running as long as you keep your finger on the soft top button (same thing with the roll bar button (Keeps running). It seems the soft top doesn't know it's through it's cycle or reached the end of it's cycle thus throwing all the soft codes.

Anyone seem similiar issues? Even after a supposed rebuild? Wondering if brookings had success with their rebuild?

Also

I had the local Mercedes dealer send out their mobile tech. He said the controller was bad. This was after I got it back from BBA. He stated that it's possible we installed it incorrectly.
Meaning installed it with a low battery, or spiked it in someway. I sent the unit back and it came back to BBA with the same issues once reinstalled. With the hard codes not resetting it makes me think it is a bad controller since the codes will not clear at all. However, my other thoughts are that it could be a switch that is not telling the controller that the cycle is ended. Or else a microswitch not telling the top that the cycle has ended.

Some I found odd was we are able to do some actual values on the top and when the top is up I am being told that the rotary switch on the left is open and on the right is closed. I would assume these two should both say closed when the top is up (or both say open) but not both rotary switches saying oppisite values. The last few hours I have been completely unable to communicate with the unit which could be controller related or could possibly be my testing equaipment (A Launch X431 machine). The issue is baffleing to say the least.

Now to summarize. The ONLY thing I have not tried (other than testing microswitches for continuity) is to manually place the soft top into the compartment and resync them that way. But I am assuming that if I can get my top down into the compartment automatically then resyncing can be done this way then no need for manually lowering it.

With that said I can make the top work if I disconnect the controller but the main problem seems to be when lowering (or raising) the top or roll bar that the cycle never stops I keep hearing the motor running. So it doesn't seem to recognize the end of the cycle.

Something else odd I have seen is the rotary switches both left and right actual values. When the top was up one side showed open and the other side showed closed. I would assume they should both show the same values?
Both open or closed not opposite values.

I was going to do further actual value tests but my scanner can no longer read, I getting 'error communicating'. When I do a short test for the whole system the test will stop on the 'RST' test and go back to the begining. So this could now be a faulty scanner (Launch X431) or the 32pin connector on our scanner.

Any input?
 

·
Outstanding Contributor
2003 SL500, 2003 SL55, and four R129s
Joined
·
4,261 Posts
Code 133 indicates a faulty controller, and the solution is to replace it. So that is more than a little daunting to me. The code 124 is for "illogical" signals from the limit switches. This is a critical fault that is simple to troubleshoot. I think I would start there.
 
1 - 2 of 2 Posts
Top