Mercedes-Benz Forum banner

1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
Hey,<br> <br> My clk just happens to like getting problems. It has 9500 miles, and the convertible top hydralics blew, the ignition switch went, and the tire wear is horrible<br> <br> TO ADD TO THE LIST, today im driving as usual in drive. I kicked down the accelerator to the kick down to accel. The friggin car just sits there revving like its in NEUTRAL, i tried switching to neutral, and back, and it wouldnt go. THen i tried using the manual mode to no avail. I got it going again by shutting it down and restarting it. Has ANYONE HAD SUCH A PROBLEM??<br> <br> Prior to this, when ever the car is switched from r to d it sort of lugged and would sometimes stall. I REALLY hate going back to the dealer for this crap but this problem i think is major.
 
G

·
Discussion Starter · #3 ·
I think my dealer breaks it on me!

Everytime i leave them a new problem arises. I went to have a simple window regulator replaced, and when i go to pick it up the damn car wouldnt even crank over. Another 2 weeks in the shop...<br> <br> God i can imagine what this one will cause<br> The car was bought new by me. It still has warrenty, but its getting REAL excessive on the amount of stuff that breaks on it. Not little things either, i can live with those. The damn convertible top hydralic system blew out the first month i had the car.
 
G

·
Discussion Starter · #4 ·
I think you should change to another MB dealer, maybe you'll find a better place to fix your car
 
1 - 4 of 4 Posts
Top