Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
2008 c300
Joined
·
5 Posts
Discussion Starter #1
I just got my 99 c230 last month and found out that fuse #4 located inside the trunk is missing. i know it is for the rear defroster but not sure what amp bec the guide insert is missing too!. is there anyone who can give me the fuse specs? or maybe the specs for all the fuses. tks!
 

·
Registered
'99 2.3L Kompressor
Joined
·
1,944 Posts
I don't have access to my manual right now or I would try to look it up for you. Why don't you call the Mercedes help line 1 800 For Mercedes or whatever it is.
 

·
Registered
2008 c300
Joined
·
5 Posts
Discussion Starter #3
i already called to the dealer to buy the fuse but they don't know too what amp. It's not in their system (parts). So it will be a big help if you can find it for me. many thanks.
 

·
Registered
2008 c300
Joined
·
5 Posts
Discussion Starter #5
thanks for the diagram but what i really need is the one located inside the trunk, spare tire compartment. If you'll get a chance pls post/attach the copy. tks!
 

·
Registered
1996 Silver C36
Joined
·
543 Posts
It's not a diagram. It's a two tables! benzpimp has given you all the information you need.

If you look at the first table for"Heated rear window" you will see fuses 41,2*,4*.
If you look at the legend Identification = "*" you will see "corresponding fuse in the trunk".
If you look at the second table 2* and 4* you will see "fuse rating" is 5A and "color" is beige.

Welcome to benzworld!
 

·
Registered
2008 c300
Joined
·
5 Posts
Discussion Starter #7
OzC36,
Yes, fuses 41,2*, & 4* are for the heated rear window but bec fuse 41 uses 5A, it doesn't mean fuses 2* & 4* will use the same rating. NO! If you'll try to look again on those diagrams (what i know, diagrams are also known as tables or charts) you will not find any info about 2* & 4*. And as you mentioned, the legend says "Identification "*" = corresponding fuse in the trunk ... Note: Observe correct amperage! Further fuses are located in the trunk" So, I think my real problem is that my fuse box diagram that is located inside my trunk is MISSING! as well as the fuse 4*. That's why I have no any idea what fuse to use. If you'll use 5A for 2* 4*, it will just get burned once you turn on the defroster. I believe the rating should be higher than 15A, maybe 30 or 40? Help!
 

·
Registered
2008 c300
Joined
·
5 Posts
Discussion Starter #9
thank you benzpimp.

by the way i just lowered my car with eibach pro kit springs now i need the camber alignment kit. anybody knows where can i get 'em?
 
1 - 10 of 10 Posts
Top