Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
Hello All,

I have a 1997 S420, and I can't seem to figure out why my front fog lights will not come on. I just installed new bulbs today, checked the fuse about a 100 times, and still no light. Has anyone ran into this type of issue?

Luke
 

·
Registered
1987 560SL - 1994 S420 - 2005 S55 AMG
Joined
·
341 Posts
Please excuse the obvious, but you do have the light switch pulled out, not just turned to on? There are 2 stops, one for the fronts and another for fronts plus rear.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #3
I have already done that, the strange thing is that there is no light (emblem) illuminated on my dash. So this is puzzling me now. Do they only operate while the car is actually being driven?
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,564 Posts
Hi
Happen'd to me , make sure that the new light globe is fitted in properly it has sort of 3 dots into where they suposed to fit in ,that is if yours r H3 Globes,it's easily installed upside down by not knowing ,did you check the Foglight Fuse not only the Headlight fuse,obviously u know to pull the Headlight switch out ,pull it all out ,wont hurt if the Red rear fog comes on .
Ciao
The fog's will work with just the Ignition on no need for the Engine to run .
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
The switch itself has a light in it to tell you that the foglights are on. Sometimes the switch can wear out and not click in also.
 

·
Registered
1973 W115 200 /8
Joined
·
895 Posts
Also. Do not forget that the could be a connection problem at the back of the lamp-housing..
I had that problem on my fog-lights.. The right one never came on, on first attemt.
Just popped the hood, and wiggled the connector on the back of the housing a bit, and then it worked ok..
Does the "broken-light" lamp in the dashboard light up ?
 

·
Registered
Joined
·
149 Posts
Discussion Starter #7
The light in the dash will pop on every now and then, but will not stay on. Also I have noticed that when I pull out the light switch to the first pull, the light on the knob will not come on, but it will come on for the rear fogs, does this help any?

Luke
 
1 - 7 of 7 Posts
Top