Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
96 s320 and 97 e320
Joined
·
35 Posts
Discussion Starter #1
When I bought my S last year the remote didn't work. Recently I noticed there was no microswitch on the circuit board and today I soldered one in. I can see the led in the remote light when I push the button but it doesn't flash the inside rearview mirror. I didn't bother for a long time because my drivers door has a key hole for entry. My 97 E320 has a sensor at the drivers door instead of a key hole and a sensor on the trunk. I don't see these sensors on my S. I have the same red/green lights on my mirror. Am I supposed to have remote lock/unlock on my S. If so, is there a way to get it working without visiting the dealer? I already inserted the key and turned the vehicle on. Am I missing something like when you replace a battery?

Thanks in advance for any insight...
 

·
Moderator
93 SL500, 95 SL320, 96 S320, 98 S500, 2002 E320 4Matic Wagon & A little 91 5.0 FORD Mustang
Joined
·
8,064 Posts
All 96 Mercedes cars were special, and were different when it came to the remote. The remote pick-up sensor is the little black cap under the rear-view mirror in the center, and their are a green and red lamp/led that light-up when the unlock and lock button are pressed on the bottom of the rear-view mirror.

Your remote does have some batteries in it. i believe they are two 3v coin batteries.

A quick way to test your remote(your remote is IR-Infrared-like the TV and DVD remotes-line of site) is to point it at a security camera, and look a the white high-speed flashes on the screen, or point it at a camcorder and look on the screen to verify the IR signals is coming out.

Hope this helps,

Martin
 

·
Registered
96 s320 and 97 e320
Joined
·
35 Posts
Discussion Starter #4
THANKS wasimtiger. I've got it working already. I read the link you posted and found this in there. Note the last sentence where it is stated that this procedure is ONLY for the S...

"ok your vehicle may have been produce before the process i described. the older method is this.
1.) production up to 12/93 point the remote at the door handle, press the button and within 30 seconds lock and unlock door with key and it should recode.
2.) production as of 1/94. point the remote at the door handle, press the button and within 30 seconds switch on the ignition then off and it should recode
3.) production as of 12/94 (has a differnt key part number try this too) point the remote at the door handle, press the button 2 times and within 30 seconds turn the ignition to position 2 and off and it should recode.
so these are the possibilities. im sorry about the previous info it was for all cars BUT the s class. so try all 3 ways."

Mine is a 96 S so I tried option 3 first with a modification. As I inspected my drivers door looking for a possible receiver I noticed the part of the handle that has the key looked NEW as compared to all the other handles. Assuming there wasn't a receiver there I pointed my remote at the trunk where I thought I didn't have a receiver but I noticed to the left of the key hole was a square fresnel looking patch. I pushed the remote twice, hopped into the car and turned the key to position 2, then turned to off and pulled out the key. Immediate success!!!!!

You guys on this board absolutely rock! I have had several questions answered completely and accurately in the past few weeks on both my S and my E. Thanks again....
 

·
Registered
300E S320
Joined
·
5 Posts
Hi guys need help
my s320 96 remote locking has stopped working no lights on the rear mirror key still starts and car runs but i cannot lock it
any ideas would be appreciated
 
1 - 7 of 7 Posts
Top