Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
2001 Mercedes Benz ML430 w163,2008 Mercedes Benz CLS550, RIP Mercedes Benz 1996 e320 w210
Joined
·
520 Posts
Discussion Starter #1 (Edited)
Hi

My 96 e just stalled on the hot day on traffic lights. So I drove it home stalling about 7 times on the way.

So I assumed it was my CPS so i decided to change that sucker.

And the car still stalls. Just starts has hard time and stalls like same as with a bad MAF. Looks exactly like MAF issue I had which it just stalled upon start up.

So any advice from you fine folks would be greatly appreciated:)

Thanks in advance


Sent from my Autoguide iPhone app
 

·
Registered
2001 Mercedes Benz ML430 w163,2008 Mercedes Benz CLS550, RIP Mercedes Benz 1996 e320 w210
Joined
·
520 Posts
Discussion Starter #3 (Edited)
Well prior to this mishap my friend was trying to help has cleared the codes about 2-1 week before it stalled on me but I got CEL on about 1 day before stalling issue(but prob not all codes ). But when I scanned it(after stalling happened) I only got p041(prob wrong just top of my head) which I checked to be my post cat O2 sensor.

I already have the O2 and will be replacing once I get some bigger tools for the removal and install of the sensor.

But I don't think that oxygen sensor can cause such symptoms? I mean doesn't a bad O2 causes running rich?

Note: the sensor is very bad since my CATs been replaced prob cuz of bad O2 which I haven't replaced in long time:) so what do you guys think?

I will try and scan this beast again tho.

PS how do you check the pending codes?



Sent from my Autoguide iPhone app
 

·
Registered
2001 Mercedes Benz ML430 w163,2008 Mercedes Benz CLS550, RIP Mercedes Benz 1996 e320 w210
Joined
·
520 Posts
Discussion Starter #4
Ok so I think it might be my EGR valve so my plan is to take it out and clean it. But I puzzled looking at the attached photo I pretty sure EGR is the top one on the picture but what is the second(bottom) thing?? It looks like some sort big brother of EGR valve:D

Also I tried looking for EGR files on the WIS but didn't find any. Am
I searching it wrong?(just got WIS/Asra)

Thanks



Sent from my Autoguide iPhone app
 

Attachments

·
Registered
2001 Mercedes Benz ML430 w163,2008 Mercedes Benz CLS550, RIP Mercedes Benz 1996 e320 w210
Joined
·
520 Posts
Discussion Starter #5
Alright the second thing is my air injection valve.

I think maybe a good clean to both should fix my issues.


Sent from my Autoguide iPhone app
 

·
Registered
2001 E430 4matic
Joined
·
419 Posts
You do not even bother to present our members with a code to help you ....

By the time you are done, you are proud owner of a "kind of" a brand new Mercedes :D
 

·
Registered
1990 Mercedes-Benz 420 SEL(RIP),1997 Mercedes-Benz E420
Joined
·
1,936 Posts
You're already at a disadvantage when trying to resolve a problem through a forum since we cannot physically see the vehicle. We are only able to make our best assumptions based upon the question we ask and information you provide.

We need codes, symptoms, etc... just to name a few to make an accurate diagnosis.

I'd say have the codes read again, write it down on a pen and paper, erase it...then drive the car a bit and then see what codes reappear.
 

·
Registered
2001 Mercedes Benz ML430 w163,2008 Mercedes Benz CLS550, RIP Mercedes Benz 1996 e320 w210
Joined
·
520 Posts
Discussion Starter #8
Thanks I understand that but
I can't drive it it stalls before I put in gear but I will get a good scanner and scan it.
I just wanted to know if anyone had similar problems in past.


Sent from my Autoguide iPhone app
 

·
Registered
2001 Mercedes Benz ML430 w163,2008 Mercedes Benz CLS550, RIP Mercedes Benz 1996 e320 w210
Joined
·
520 Posts
Discussion Starter #9
You do not even bother to present our members with a code to help you ....

By the time you are done, you are proud owner of a "kind of" a brand new Mercedes :D
What do you mean?

I haven't got a scanner so I don't even have the codes...


Sent from my Autoguide iPhone app
 

·
Registered
2001 Mercedes Benz ML430 w163,2008 Mercedes Benz CLS550, RIP Mercedes Benz 1996 e320 w210
Joined
·
520 Posts
Discussion Starter #10
Problem solved

It was big vacuum line under the air intake that was cracked.
 
1 - 10 of 10 Posts
Top