Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
mercedes e320 w210
Joined
·
6 Posts
Discussion Starter #1
Hi,

I own a 96 model e320 u.s. version. last week my car wont rev past 3000 rpm. But there is no check engine, and i can use all the gears and i just changed my atf and transmission filter. the car is driveable and seemed that there are no problems except for it having a limit at 3000rpm. Can anyone help me on how I could fix the problem, check maybe some sensors or how to reset?

Thanks in advance...
 

·
Banned
1999 E300 TD
Joined
·
2,045 Posts
Hi.. I cant rev above 2500rpm when mycar is in P or neutral. and my car wont rev past 3000rpm when in D, 3 or 2nd gear.?
Well the good news is that I doubt that the issue is with the transmission. If you were in mechanical or electronic limp mode, turning the ignition on and off would relieve the mechanical limp mode, but not the electronic, however when in electronic limp mode you only have access to R and 2nd gear----You have access to all gears therefore I don't believe you have an issue with the transmission.

To be honest there are loads of electronic things that would limit the cars rpm, but which one??? I am also amazed that the check engine light has not come on----what ever!!

My only suggestion is to find a good mechanic with MB experience or after all said and done it my require a trip to the dealer----I know expensive, but they will at least have the diagnostic equipment to locate the problem---then you can fix it yourself.

Good luck!!
 

·
Registered
mercedes e320 w210
Joined
·
6 Posts
Discussion Starter #5
thanks for your advise., ill try to bring the car to the nearest mechanic and try to check the sensors. thanks again..
[/QUOTE]
 

·
Registered
mercedes e320 w210
Joined
·
6 Posts
Discussion Starter #6
Hi, i found an mb mechanic, and found out that the wirings are open, (throttle body wirings) but now, it would not rev past 1,500rpm?
 

·
Banned
1999 E300 TD
Joined
·
2,045 Posts
Hi, i found an mb mechanic, and found out that the wirings are open, (throttle body wirings) but now, it would not rev past 1,500rpm?
Sorry, but a little confused-------You found a mecanic who found the problem, but have you fixed the problem??

Is the problem with,what you are calling, the throttle body wiring???
 

·
Registered
2001 SLK 320(217K Miles), 2002 E320 Special Edition(183K Miles)
Joined
·
3,467 Posts
Or is it the throttle position sensor - the potentiometer sensor that determines how far you have pressed the throttle pedal?
 

·
Registered
2000 E320
Joined
·
131 Posts
Or is it the throttle position sensor - the potentiometer sensor that determines how far you have pressed the throttle pedal?
Kobus i had a similiar problem with my car, but only when I floor the car. Before it used to give me check engine light, with a Throttle Valve Actuator Code, now the car just hesitates that's only if I floor the car, something that I never do, so as far as I am concerned I can live with it. Also this problem its a good thing sometimes so when my younger brother has the car he wont be able to drive fast and floor the car..lol isn't that genius? loool
 

·
Registered
mercedes e320 w210
Joined
·
6 Posts
Discussion Starter #10
Sorry, but a little confused-------You found a mecanic who found the problem, but have you fixed the problem??

Is the problem with,what you are calling, the throttle body wiring???

THe MB mechanic found out that i have a faulty wiring (throttle) so he tried to rewire it. But it seems that it even got worse. Is there a way how to fix the potentio meter sensor or throttle position sensor? or way of adjusting it? thanks
 

·
Registered
mercedes e320 w210
Joined
·
6 Posts
Discussion Starter #11
I repleced new throttle, new maf, new wiring harness, new crank sensor, but still, the car wont rev past 2500rpm? what should i do? is there a problem with my ecu?
 
1 - 11 of 11 Posts
Top