Mercedes-Benz Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
2 random (and pretty unimportant) questions on my 95 e320.

1) The lights on both driver and pass sunvisors don't come on. Doesn't bother me but the wife likes to put makeup on so...

2) The rheostat in the instrument cluster that controls all instrument illumination is possessed. If I touch it, the lights flicker off.. if I hold my mouth just the right way, they come back on at random levels of brightness.

How to fix both ?
 

· Premium Member
About a dozen 1988, 1989, 1990, and 1991 sedans, wagons, 4Matics and 1 coupe
Joined
·
5,524 Posts
Let's start with 2) because that's easy.

Like virtually all cars made since long before my time, the dimming rheostat is a length of ni-chrome wire wrapped around a piece of ceramic. When you twist the dimming knob you are moving a contact up or down the wire effectively changing its length (and resistance).

Over time the ni-chrome wire oxidizes and there is poor contact between the wire and the contact. You need to remove that oxidation and the way that you do that is my twisting the dimming knob from one of travel to the other about 50 times. Just sit in the driver's seat and twist the knob back and forth, back and forth, back and forth, as necessary. At first you will probably notice a squeaking sound but that will diminish as the contact areas clean up. In the vast majority of cases this simple action will solve the herky-jerky dash light dimming problem.

As for the illuminated visor vanity mirrors, they're powered off fuse #9 but in a weird way.

First wire goes to the front dome lamp assembly. Does that work? Do the red seat belt warning indicators work? If the answer is yes, power is getting from fuse #9 to the dome lamp assembly.

Power passes through the dome lamp assy circuit board and leaves via a separate contact that leads to the vanity mirrors. The tricky part is that power passes through the clips that secure the inboard part of the sun visors.

So, are the visors snapped into their clips? If not, clip them.

If they are, the contacts in the visor clips may be damaged or disconnected. Someone not familiar with the setup may have screwed them up trying to remove them. I've seen this several time on junkyard cars.

Report back and we'll take it from there.
 

· Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
Thanks

Very helpful.

The rheostat fix worked. Thanks.

For the visors, the dome lights, and blinking red seat belt lights both work.

I think I'm not getting power to the little contacts in the visor clips (they are both clipped in securely and contacts look to be clean, not corroded or tarnished). Question -- do they ground through these contacts or is 12v through them (or is it both)? I'm wondering if during some repair they weren't connected.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top