Mercedes-Benz Forum banner
1 - 2 of 2 Posts

· Registered
1994 C280
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello. I have been having a bit of trouble with my C280 lately. Sometimes, when trying to accelerate, the car suddenly stumbles and I swear I even hear a pop in the exhaust (excess fuel being dumped?). I pulled the following codes.





I've done some research, but have found conflicting answers. Could it just be bad gas? I only run 93. Any help would be appreciated.
 

· Registered
1994 C280
Joined
·
9 Posts
Discussion Starter · #4 ·
Check for vacuum leaks first or disconnected vacuum lines. I'm not sure what the engine bay looks like on your model but if it has a secondary air pump, check all the lines going to and from it.

Then clean the MAF, throttle body, inspect spark plugs or change them if they haven't been changed in a while, delete the codes, and take it for a test drive.


That above tool is vital for any driveway mechanic to own. You disconnect the big rubber hose from your air filter box, shove that cone in the hose, and if you happen to vape or smoke, blow vape/tobacco smoke into the hose (you may need to attach another hose if it's not long enough), keep blowing smoke and listen for hissing or watch for leaking smoke coming from anywhere.

In a pinch, you can also take a strong rubber glove, cut the middle finger off, shove a hose of some sort inside the finger, tape it up, and stretch the hand opening around the big rubber intake hose and do it that way.
THank you for taking the time and effort to give me the info. I will check the vacuum hoses for cracks. To be clear, this stumbling has only happened a few times. Would a vacuum leak cause issues constantly?

When was the last time you replaced your plugs? miles?
I am not sure on the age of the plugs plugs. I have had the car for only about a year. I'll check my service records and pull the plugs to see how they look.
 
1 - 2 of 2 Posts
Top