Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Gentlemen,

Since what I've got on my hands is a bit (ok, a LOT) newer than what I typically deal with, I was wondering if anyone may be able to shed some light on a problem child;

We replaced the header rail latches on this '93 cab and now have the three warning chimes and a lit up soft top switch. Oddly though, the top works just fine both up and down. Anyone with more experience with these tops who can offer some advise, I'd be most grateful.
 

·
Registered
1995 E320 Cabriolet, 2007 E350 Sport P2, 1995 E420
Joined
·
406 Posts
Gentlemen,

Since what I've got on my hands is a bit (ok, a LOT) newer than what I typically deal with, I was wondering if anyone may be able to shed some light on a problem child;

We replaced the header rail latches on this '93 cab and now have the three warning chimes and a lit up soft top switch. Oddly though, the top works just fine both up and down. Anyone with more experience with these tops who can offer some advise, I'd be most grateful.
This may help

http://www.benzworld.org/forums/4091215-post57.html
 

·
Premium Member
2014 G550, 2000 SL500, 1995 E320 Cabriolet, 1980 TR8
Joined
·
1,326 Posts
There is a micro-switch on each latch that tells the controller if the latch is open or closed. Check that both switch connectors are plugged in and that the micro-switches themselves are not broken (are the replacement latches used or new).
 
1 - 4 of 4 Posts
Top