Mercedes-Benz Forum banner
1 - 8 of 8 Posts

·
Registered
1993 190E 2.6, 1990 300SEL, 1992 300SE, 1992 400E, 1987 190E 2.6 murdered by my brother.
Joined
·
1,291 Posts
Discussion Starter · #1 ·
hi guys. I need your help again. I bought this thing called Cool Harness which turns on the aux. fans in my car right at 92 degrees Celsius to keep the car cool so that the high speed aux fans dont crank on when the car is about to cook itself. Problem is the directions it came with does not show a Inline 6 engine. It shows the 190E 2.3 engine which is the 4 banger. Does anyone know where the CTS is located in the engine? Thanks.
 

·
Registered
1992 190E | 1997 BMW 328i | 2001 C320 | 2004 C230K | 2007 BMW 335i
Joined
·
346 Posts
It's on the head, next to the valve cover. There are 3 sensors that stick out of the head. It's the one which is closest to the front of the car, and has some blue color on the sensor.
 

·
Registered
1993 190E 2.6, 1990 300SEL, 1992 300SE, 1992 400E, 1987 190E 2.6 murdered by my brother.
Joined
·
1,291 Posts
Discussion Starter · #3 ·
Yeah I was looking for the tell tale blue wires but I dont see any around the thermostat bell shaped cover. The directions show for it to be there for a 190E 2.4 but mine is a 2.6 and has the air filter sitting over where it is suppose to be. possible to bother you for a pic? The only blue wire I see is right next to the air condition compressor so I dont think that is the CTS sensor I am looking for.
 

·
Registered
1992 190E | 1997 BMW 328i | 2001 C320 | 2004 C230K | 2007 BMW 335i
Joined
·
346 Posts
No, it's literally screwed INTO the head, right on top of the motor, not by the t-stat or anything. You can still see it with the filter there, you don't need to remove it.

I can't take a pic, I don't have the car with me right now.
 

·
Registered
1993 190E 2.6, 1990 300SEL, 1992 300SE, 1992 400E, 1987 190E 2.6 murdered by my brother.
Joined
·
1,291 Posts
Discussion Starter · #5 ·
OK Chowbow...Im going downstairs to look at it again. Its really dirty in there and was hot earlier so I was getting burned while trying to replace this. I will let you know what I turn up.
 

·
Registered
1993 190E 2.6, 1990 300SEL, 1992 300SE, 1992 400E, 1987 190E 2.6 murdered by my brother.
Joined
·
1,291 Posts
Discussion Starter · #6 ·
Found it! Thanks for your help bro. It was in the middle of the inline 6 engine block. Brittle plastic from heat damage. When i tried to pull it out...it shattered. Luckily it still worked so I plugged it into my Cool harness and now when the cars coolant temp reaches 92 C the fans kick on to cool the car down. Works great in Las Vegas now.
 

·
Registered
190e 1992 2.3 Mercedes
Joined
·
23 Posts


I had a leak with this sensor as it would not seat and seal. Replaced the small washer with a thicker copper on and tightened in. No tep guage now. The black plastic part on top is moving so I am guessing that means the internal wiring broke??? The plastic on top for wire is broke o I am hoping that someone can tell me green goes to the one plug on rear and then there are two plugs to front green/blue/black and blue/black. Does it matter where they go or can some one tell me where colors should be left and right
 

·
Registered
'87 190E 2.6
Joined
·
186 Posts
The connectors on the temp switch do not matter side to side; unless keyed differently. Yes if the plastic spins within the switch the switch is dead.

The green two pin switch closest to the firewall is the coolant temp to the ECU (determines open/closed loop for mixture adjustment). If that switch broke changes are you are running rich all the time.

HTH.
 
1 - 8 of 8 Posts
Top