Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
1998 Mercedes SL500
Joined
·
52 Posts
Discussion Starter #1
I would appreciate advice from anyone who knows this problem. As the title says, my 91 convertible top will not come up. Here's the story...briefly;

About 3 weeks ago, my roll bar started to pop up if I went around a corner even slightly. When this happened, I could not put the top up or down. I found out that if I held the roll bar switch in the up position, I would hear a click, and then it would go down. The top would then work.

Yesterday, I went out to start the car, and it was dead. Mystified, I jumped it. It wouldn't start. My car always starts easily. This was alarming. So, I let it idle to charge the battery some. Came back 30 minutes later and although a struggle, it did start up and ran normally. I dropped the top and went into town. Once I arrived, I tried to put the top down. The red button would blink, but absolute silence. Nothing was engaging. I checked the front and rear fuses...all good.
UPDATE 8.13.12:
After the battery decided to die (3rd time replacing it), and installing a new one, I thought that in moments after reading the error codes and correcting them, I would be back to normal. No. Now, instead of blinking (the convertible top code 1/10) the top button on the console has a steady light when crossing ground (1) with the convertible terminal (10). My roll bar is dead in the water, too. It stays up and won't move.


With the superb weather, this is not a bad thing. But, as Seattle weather goes, this is the exception. Sooner or later, it's gonna pour and I'm going to be stuck. Any ideas to help a battered Benz owner?
 

·
Registered
2009 S550, 1973 Avanti II, 2008 Silverado LTZ
Joined
·
899 Posts
Bump for a friend....
I've tried to advise on the problem, but I haven't actually had a chance to work on it!
 

·
Registered
Departed 1998 SL500 (and the Pano is in Bogota)
Joined
·
11,116 Posts
You need to solve the rollbar problem first, the top will not operate until the rollbar is down.
 

·
Registered
03 SL Kleemann, 97 SL320, 95 E320 cab, Tesla X, Ferrari 360, etc
Joined
·
949 Posts
Fix the roll bar problem first

You need to solve the rollbar problem first, the top will not operate until the rollbar is down.
I agree with RKH - you need to get the roll bar operational first, and eliminate the reason for it deploying when you zip around corners. Have you checked roll bar codes yet, and are you ready to work on the sensors causing the roll bar to deploy too easily?

Klaus

Top Hydraulics | Rebuilt Convertible Top Hydraulic Cylinders - Top Hydraulics, Inc
 

·
Registered
1998 Mercedes SL500
Joined
·
52 Posts
Discussion Starter #5
Thanks Klaus and RKH,

I'm trying my best to learn everything I can about this car to fend off these monthly problems. This one has been especially baffling. But, it's starting to make more sense now.
I'm going to head over to Warren's place this afternoon and see if we can pin down and identify the problem. Stay tuned!

Clancy
 

·
Registered
Departed 1998 SL500 (and the Pano is in Bogota)
Joined
·
11,116 Posts
In the mean time you can just reset the rollbar to get it down so that you can operate the top when it rains.
 

·
Registered
1998 Mercedes SL500
Joined
·
52 Posts
Discussion Starter #7
I was aware of how to reset the roll bar. Apparently, I didn't engage it long enough. Warren reminded me to try it again. This time it worked. The top functions now. But, the roll bar still pops up with the slightest movement while driving.
We tried to read the codes, but when crossing terminal 1 with the roll bar one (I believe it was 7 and the soft top was 10 or vice versa) all we got from either 7 or 10 was a steady light...no blinking. Does anyone know what gives?

Also, I'm getting the feeling the roll bar sensor is crying, "me next" to my wallet! Does anyone know where it is located?

Always appreciative of shared knowledge, here!

Clancy
 

·
Registered
Departed 1998 SL500 (and the Pano is in Bogota)
Joined
·
11,116 Posts
The rollbar deployment for the early R129 is activated by lever and switch at the rear suspension. May just need adjustment.

Now if you just raise the rollbar before you drive, then hopefully road bumps will not trigger emergency deployment. If that works, you can just keep the rollbar raised all the time and your soft top will always work when you pull/push the red button.
 

·
Registered
2009 S550, 1973 Avanti II, 2008 Silverado LTZ
Joined
·
899 Posts
Does anyone have any idea why it refuses to go into the diagnostic mode? I'm sure we did it right; Key in position 2, short between 1 and 7 for the roll bar and 1 and 10 for the soft top.
The lights go steady on, no blinks.:surrender:
 

·
Registered
2009 S550, 1973 Avanti II, 2008 Silverado LTZ
Joined
·
899 Posts
Just bumping this up in the hope somebody can explain why we can't get into diagnostic mode?
 
1 - 10 of 10 Posts
Top