Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I am new to this site and I have just purchased my first Mercedes-a 1991 300 CE. The car has 134,700 miles on it and is in very good condition. It was owned by an elderly gentleman who never drove it in the winter. The car does have a few "issues". The climate control will not blow heat onto the floorboard, the instrument panel has a bulb out over the tachometer and it seems as though the engine RPM is too high at cruising speed. Is 2,500 rpm normal at 55mph? It seems as though the car starts out in 2nd gear unless you really push the throttle hard from a stop (3/4 way to the floor). Is this normal? How do i replace the instrument panel bulb?
Thanks for any advice. This is a great car to drive and I think I'm hooked!
 

·
Registered
Joined
·
3,725 Posts
The car starting in 2nd gear from a stop is normal. It's more of a Mercedes/comfort thing. If pressing down 3/4 and more the car should kick down into first and you're on your way to going pretty fast. Engine RPM at 55mph is just about where it should be. Nothing wrong there. Replacing the bulbs on the cluster requires removal of the cluster - MercedesShopWiki: Instrument Cluster Removal -- read the DIY article. Explains removal and the bulbs used. I don't know anything about the climate control not blowing heat to the floor. Maybe someone else may offer their opinions.

Any pictures of your new found beauty?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
91 300 CE Questions-reply

Thanks for the info-especially the DIY link. I tried to attach a photo but the file was too large.
 

·
Registered
Joined
·
3,725 Posts
no problem.

you could also upload the pictures via imageshack.us or photobucket.com. you have to register for photobucket though, but you can choose what size you want your pictures and you can edit them as well. they're also saved in an album for you and will always be there. :thumbsup:
 
1 - 4 of 4 Posts
Top